WebSpeed Agent Error: OCTO error receiving page from Agent =

Posted by Admin on 02-Sep-2009 02:58

Hi All,

We have developed a web application and deployed using the following architecture:

Server A: Web Server + Webspeed Messenger ( IIS on Windows Server 2003)

Server B: Webspeed Server + Database ( Progress 10.2a on Linux openSuse 10.2)

Both the servers are on the same subnet with all ports open.

The application runs fine, there is just one problem, upload of a file. When a file is uploaded with this application, the file upload works but the page returned has the following error

WebSpeed Agent Error: OCTO error receiving page from Agent = % (6532)

This error does not occur when a Webspeed Messenger on Server B is used.

Looking up on progress knowledge base gave the following information

Symptoms:  
# Errors 6019 and 6532 displays on the browser intermittently
# WebSpeed error from messenger process (6019)
# WebSpeed Agent Error: OCTO error receiving page from Agent = % (6532)
# WebSpeed Agent Error: OCTO error receiving page from Agent =<errorcode> (6532)
# The error is apparent when the request is served by the first agent on the WebSpeed broker status list
# The WebSpeed agents port range is set to default from 3202 to 3502


Facts:  
# OpenEdge 10.x


Cause:  
# The exact cause is unknown at this time of this writing


Fixes:  
Change the srvrMinPort to a higher number then 3202 but lower then the srvrMaxport number and restart the broker.


but that did not help either.

If anyone here has come across this problem before and has been able to solve it, I would really appreciate a response.

All Replies

This thread is closed