Getting error "Cannot enable debugging for the Progress

Posted by kthras on 19-Feb-2010 10:09

Due to a problem with my laptop, I recently wiped the hard drive and installed Windows 7 (used to have Windows XP).  As part of this, I reinstalled OpenEdge.  Under Windows XP, I used to be able to enable debugging without any issues.  However since upgrading and reinstalling the softward, I'm getting the above error when I try to enable debugging.  I have adminitrator rights.  Any ideas on what I need to change in order to enable debugging?

I have checked the registry keys and I have HKEY_LOCAL_MACHINE\SOFTWARE\Secure\ProDbgCK and the name is C:\SKYWARD\dlc.state and it shows "Debugging enabled".

Skyward is a product we bought and I've wondered about the name of this and whether it is correct or needs to be something else.


All Replies

Posted by kevin_saunders on 22-Feb-2010 03:38

On my win7 install, I have:

HKLM\Software\PSC\Progress\ProDbgCk c:\Progress\OpenEdge.state Debugging Enabled

Actually, I have

HKLM\Software\Wow6432Node\PSC\Progress\ProDbgCk c:\Progress\OpenEdge.state Debugging  Enabled

but that is on 64bit Windows.

So make sure that key is set. Also, you can try running PROENV as Administrator (right-click the shortcut and select 'Run as Administrator').

Posted by kthras on 23-Feb-2010 09:02

Thank you!! Sorry I didn't reply yesterday, I was out with a sick child. I'll try setting up the first key you listed and see if I have any luck. The second one probably wouldn't work since I'm not on 64 bit yet.


Posted by kthras on 23-Feb-2010 09:52


When I looked, my key was set to HKLM\Software\PSC\Progress\ProDbgCk c:\Progress\OpenEdge\dlc.state however that file doesn't exist so I can't rename it as I thought.

I've searched for *.state on my machine and it finds 1 file called in C:\Progress\OpenEdge\prokey32 .cmake.state so it's not related that I can tell.

Can you tell me what OpenEdge.state contains and can I create it or does it have to come from the install of the OpenEdge product?


Posted by kevin_saunders on 25-Feb-2010 03:35

In the registry editor, you can right-click and select 'Rename' and rename the key.

I've just checked on another machine (XP 32Bit) and it is also called C:\Progress\OpenEdge.state

There is no file called OpenEdge.state, it is just a key with a value.

P.S. Apologies for my late reply, but I have been off ill for the past 2 days..

Posted by kthras on 25-Feb-2010 09:02

Well I finally got an answer from Progress Tech Support. We are running 10.1B and the debugger isn't supported in that version on Windows 7, we have to go to 10.1C on up. So our choices were either to go back to XP or upgrade our Progress version. We chose to use XP Mode on Windows 7 when we need to debug. It took a little work to set up the environment but it is working.

Thanks for taking the time to reply Kevin!


Posted by AJanz on 15-Sep-2010 03:50

I just had the same problem. Strangely debugging worked with 10.1A after I create the registry key


although when enabling debugging I got the message

WARNING: It appears that someone has edited the debugger
security information which controls whether debugging is enabled
with something other than this tool.

With 10.1B03 I just set _debugEnable.exe and prowin32.exe to Windows XP compatibility mode, enabled debugging, and then I could start the debugger.

This thread is closed