Installing 10.2B Win32 on Windows 7 x64

Posted by Darren Parr on 02-Aug-2011 11:22


This is proving to be a nightmare. It seems that the progress installation doesn't like my windows desktop at home.

The install looks OK and goes through normally except the registry is completely shafted. Both under HKCU/Software/PSC/Progress and also under HKLM/Software/Wow6432Node/PSC etc. there is a problem. I am getting several nodes. For example I have a 10.2B node with hardly anything underneath it and instead I have a 10.2Bv node with everything else.

I did sort it so that it all runs OK, apart from the fact that the OE explorer won't start and its missing some java class libraries which makes the install useless from my perspective.

Any ideas?


All Replies

Posted by jmls on 02-Aug-2011 11:51

If you use chrome, then humour me. Remove progress, and all the registry keys.

Reinstall, making sure that you don't have chrome running ...

Posted by Darren Parr on 02-Aug-2011 12:17

Ignore this post...

Posted by Darren Parr on 02-Aug-2011 12:22


Sorry that didn't work. I just removed chrome completely and rebooted and I still get my 10.2Bv nodes in th registry.



Posted by jmls on 02-Aug-2011 12:31

ok, another long shot - are you sure that this is basic 10.2B

installation media, not a service pack ?

How about downloading the installation package again, and unzipping it

to a fresh directory.

Also, are you running as administrator, or with "run as administrator " ?


Posted by Admin on 02-Aug-2011 12:36

Also, are you running as administrator, or with "run as administrator " ?


I recommend both.

Posted by jmls on 02-Aug-2011 12:46

interesting. I have not had a single problem installing as my regular

user login (although the account is a system admin account)

Windows 7 64 bit, progress 10.2B 32bit

Posted by Darren Parr on 03-Aug-2011 02:24


It was a while since I first instaled it at home and so I decided to trash windows and start again. THe user is not on a domain but is an administrator. This is vanilla windows 7 sp1 and I'm installaing OE Studio..

Everything seems OK until you get the warning about the MS JVM which you click through and install anyway. The most noticable things is that there is a blatant error which I recalled last time and it says the "windows blocked the install of as it has an invalid digital signature". After it all finishes the registry is as before with 10.2B and a 10.2Bu.

I just did a system restore to see if I can sort it out. BTW this works fine on my PC at work.



Posted by Darren Parr on 03-Aug-2011 03:59


The java stuff has nothing to do with this. It seems that after renaming the old java executable, I get no errors but no valid install. Running prowin32.exe just gives you an error "unable topopen file PROMSGS". Obvious considering the entire registry key is under 10.2bt at the moment.

Just sorted the registry out and rebooting.

Posted by Darren Parr on 03-Aug-2011 05:24

One for progress support I think ....

Posted by Darren Parr on 03-Aug-2011 10:49


A bit more info....

It seems that support have seen this somewhere over 90 times since 2008 with 10.2B. Thats the good news. The bad news is that they don't know how to solve it and have tried on many occassions. I was told that exact hardware and software can lead to one PC having this issue and the PC next to it not having an issue at all. The fix is to go into the registry and sort out the mess so that Progress runs. Unfortunately for me OE Explorer doesnt seem to work (fathom -q reports the plugin can't be found) and the CGI directory for installing the messenger is empty. Hence whatever goes wrong messes with the installshield completely whilst its running.

Makes me real glad all our GUI clients run webclient :-)

My solution this evening is to copy a working install with exactly the same paths ie D:\DLC10 and D:\OEM10 and copy the contents over the top of my failed install to ensure I have everything I need. I should be able to run everything then.

I must be honest and say I've never seen this before.



This thread is closed