Not licensed ...

Posted by jmls on 21-Dec-2011 15:18

Apparantly I must have annoyed the powers that be at PSC ...

trying to start my customised 3.7 eclipse environment (I know, it's not supported, but I've been using it since 10.2B) and got a whole load of errors, specifically

"Not Licenced to run Progress Developer Studio for Openedge for version: 11.0"

wtf ?

So, I thought that it must be a corruption or something. So I fire up the standard Progress Developer Studio. No dice. Same errors ...

What have I done ? This was working just fine yesterday.

The config file gives (XX hides relevant info)

Product Name:  Progress Dev Studio OE

Installation Date:  Fri Dec 16 23:15:10 2011

User Limit:  1

Expiration Date:  None

Serial Number:  004265XXX

Control Numbers:  Y9GXX - 6QGXX - N4GXX

Version Number:  11.0          

Machine Class:  KB

Port Number:  31

The licence and config files appear on ESD as well

All Replies

Posted by vjug on 22-Dec-2011 00:57

Sounds like this KB issue: . A colleage had the same error and the following solution helped:

"Alternatively, export the  10.1B entries under HKLM\SOFTWARE\PSC\PROGRESS entries from a working  installation, modify these entries manually to for pathname differences,  and import them into the bad installation."

This issue is for 10.1B but in our case worked the same way on OE11

Posted by jmls on 22-Dec-2011 03:04

not the same issue, but it led to the problem area I think.

I have just uninstalled and reinstalled the commercial release of

11.0, and have the same problem.

There is no psc or progress key in the registry under HKLM, which may

be causing the problem

so, it looks like the installation does not create the right keys in

the right place.


On 22 December 2011 06:57, Vjekoslav Jug

Posted by vjug on 22-Dec-2011 03:10

Is it maybe 64-bit Windows?

Did You checked HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PSC? All 32-bit nodes are there on 64-bit versions...

Posted by jmls on 22-Dec-2011 03:14

and of course, you are correct.


so what is wrong now ? I've uninstalled and reinstalled to no avail.


On 22 December 2011 09:10, Vjekoslav Jug

Posted by vjug on 22-Dec-2011 03:25

We exported the key, manually changed it in text editor, deleted whole key in registry (the one that we exported) and imported corrected content back in. I'm not sure what got wrong in Your case, but we had some wrong paths.

Posted by jmls on 22-Dec-2011 03:34

I don't have any other keys to export

On 22 December 2011 09:25, Vjekoslav Jug

Posted by asthomas on 22-Dec-2011 03:39

You need to check both your HKLM and HKLU keys to see if theres anything wrong with them. We have had issues with registry keys on Windows 7 64-bit several times in both 10.2B and 11.

Regards / Med Venlig Hilsen 

Thomas Hansen


This thread is closed