SQL sproc error: [DataDirect][OpenEdge JDBC Driver][OpenEdge

Posted by jwiseheart on 15-Aug-2012 13:33


     For starters, I'm new here, so please let me know if I should be posting in a different forum...   

I am trying to get stored procedures in OpenEdge SQL working for the first time. The SQL CREATE PROCEDURE statemant works fine (now that I found I had to change the delimiter to something other than a semicolon, that is...). However, we get the aforementioned error when running the CALL PROCEDURE statement. It's a 'Hello World' type example, I can't make it ant simpler, but I still can't figure out why it won't work. Here's some quick details:

Our application: Encompix ERP, developed in Progress OpenEdge 10.1C04

Our tools: OpenEdge Architect

Java version (from Control Panel in Windows): 6.0.330

OS: Windows Server Standard 2008 32-bit Service Pack 2

Code (We put all of our custom objects in an NSI namespace, so as not to conflict with Encompix):

/* NOTE: Changed OpenEdge architect delimiter to pipe symbol ( | ) to prevent conflict with Java semicolon line terminator */


    SQLIStatement Insert_HelloWorld = new SQLIStatement ("INSERT INTO NSI.HelloWorld(fld1) VALUES (’Hello World!’)") ;
    Insert_HelloWorld.execute() ;

CREATE TABLE NSI."HelloWorld" (fld1 VARCHAR(100))|

CALL NSI."HiWorld"()|   /* Here's where we get the error:  [DataDirect][OpenEdge JDBC Driver][OpenEdge] Error in Stored Procedure Execution. (7853)... */

SELECT * FROM NSI."HelloWorld"|      /* Table is created, but no data inserted... */

Environment ("D:\apps\oe10\" is the OpenEdge installation directory):

     PATH: D:\apps\oe10\bin;d:\apps\oe10\jre\bin\client;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files\MySQL\MySQL Server 5.1\bin;C:\Program Files\Dell\SysMgt\RAC5;C:\Program Files\Dell\SysMgt\oma\bin;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\

     CLASSPATH: %CLASSPATH%;%DLC%\java\openedge.jar;%DLC%\java\util.jar;%DLC%\java\base.jar;%CLASSPATH%



So, as you can see, I've checked the Java environment variables & registry keys,  but still get an error any time I run the simplest of java snippets inside an OpenEdge stored procedure. Any ideas? Also, all the documentation talks about Java version 1.4.x or 1.5.x. Is it a problem to have a newer version of Java than that? 

Thank you,

Joel Wiseheart

All Replies

Posted by jwiseheart on 13-Sep-2012 12:19

Okay, I finally fixed the problem. In many different OpenEdge documents, it gives a list of environment variables and registry entires to check. However, in "Progress OpenEdge 10.2B - Getting Started_Installation and Configuration," under the "Java Considerations" section, it states: "Many OpenEdge products require the Java Run-time Environment (JRE), the Java Development Kit (JDK), or both of these components to use specific product functionality once the products are installed. The OpenEdge installation automatically installs the required JDK/JRE components in Windows."

Sure enough, I re-ran the installation program to put OpenEdge Architect on our server, and something in the installation caused the Stored Procedure java snippets to start working. So, if you see this problem, try re-runnning you installation.

Joel Wiseheart

This thread is closed