OpenEdge Architect remote DB Connection

Posted by rrajan on 22-Jan-2013 05:25

I have a OpenEdge installed in my windows desktop. I have an OE application running in unix. I would like to connect to that application DB by Default when opening the OE Architect. Is it possible to connect to that ? What informations do we need inorder to connect ?

All Replies

Posted by Matt Baker on 22-Jan-2013 14:21

At a minimum you would need the host and port number the database is running on.  You can gather the port number from the database startup log (-S parameter).

From within OEA you can select window->preferences->progress openedge->database connections to setup your database connections.  Select one of them when you create a new project.

Posted by rrajan on 23-Jan-2013 01:47

I have the -s paramter as a service in the server. How do we know the port number in that. If I provide the service name I am getting error 5192. Please help me in resolving the issue

Posted by Admin on 23-Jan-2013 01:50

Please keep in mind that Progress startup parameters are case sensitive and so -s and -S are two completly different parameters.

For the port number/service name on a DB server and client connection, use the -S parameter (uppercase) followed by a port number or service name known from /etc/services or c:\Windows\System32\drivers\etc\services.

Posted by rrajan on 23-Jan-2013 04:03

Now I got the port number from the etc/services and instead of the service I have mentioned the port number but now I am getting an error "Count  not connect to server for database xxxx, errno 0"  1432. Please help me in resolving the same.

Posted by Rob Fitzpatrick on 23-Jan-2013 10:11

So there is no SQL server available for you to connect to, which could have a variety of causes.  On the DB server, connect to your database with promon:

promon /path/to/yourdb.db

(I am assuming your DLC and PATH environment variables are set correctly.  If not, you now have two problems.)

If you still get a 1423 error when you enter the command above, then your database is offline.

If your database is up and you get into promon, enter R&D from the main menu (Advanced Options), then 1 (Status Displays), then 17 (Servers By Broker).  Post the output here.

Posted by rrajan on 23-Jan-2013 11:52

01/23/13        Status: Servers By Broker

Sv                                                   Pend.   Cur.   Max.   Port
No    Pid  Type       Protocol               Logins  Users  Users  Users    Num

  0   6358 Login      TCP                       298      0      0     35  12518
  1   6367 Auto       TCP                       267      0     28     35  20011
  4  14325 Auto       TCP                        31      0      6     35  20055

  2   6365 Login      TCP                         0      0      0     35  27247
  3   6388 Auto       TCP                        62      0      3     35  20008

This is my output in promon. Please help me in connecting to the database from OpenEdge Architect

Posted by Rob Fitzpatrick on 23-Jan-2013 12:30

So PID 6358 is your primary login broker (4GL I assume), listening on port 12518, and PID 6365 is your secondary broker (SQL), listening on port 27247.  You have one server that has already been spawned by the SQL broker, with 3 of 35 user connections in use.

As I said there are several possible causes.  You could have a firewall issue preventing connection to the server.  Or you could have a port number collision that prevents a new server from being spawned.  It looks like your minport/maxport ranges for your brokers overlap, which is not ideal.

It would be helpful to know your broker command lines and your startup parameters.  Post the portion of your database log from its last startup, starting at the (333) message ("Multi-user session begin."), and about the next 80 lines after that.  Also, post the command lines of your brokers:

ps -ef | grep yourdbname | grep _mprosrv | grep -v " -m1"

This thread is closed