Saving pages or trigger is very low

Posted by ddessertine on 21-Feb-2019 16:29

Hello,

I'm migrating from RB 2.2.2 to RB 5.3.1 and Ihave some problems with saving pages.

I have a Mysql 5.7 Percona Cluster for Databases and it work like a charm with 2.2.2 but when I modify page in 5.3.1 it takes a long time save (more than 20s).

If look in slow query I have nothing.

I have the same behaviour if I change a trigger.

My RB env is mutliserver in cluster mode (2 masters, 2 prod1, 2 storage1, ...) on ubuntu Server 18.04 + tomcat 9.0.14 + java 1.8.0_201, 4cpu 8Go RAM each

Thanks

David

Posted by Srinivas Panyala on 22-Feb-2019 11:20

Could you please log a support case?

Thanks

Srinivas

All Replies

Posted by ddessertine on 22-Feb-2019 08:27

For more informations :

If I shutdown one of the 2 prod1 server saving is very fast but when I restart the second prod1 saving is very slow.

I didn't change any configuration in the prod-cluster-conf.xml file, only memebers IP :

<hazelcast xsi:schemaLocation="" xmlns="www.hazelcast.com/.../config"
xmlns:xsi="www.w3.org/.../XMLSchema-instance">
<instance-name>PROD1</instance-name>
<network>
<port auto-increment="false">5703</port>
<reuse-address>true</reuse-address>
<join>
<multicast enabled="false"></multicast>
<tcp-ip enabled="true">
<members>192.168.50.90;192.168.50.91</members>
</tcp-ip>
<aws enabled="false"></aws>
</join>
</network>
<group>
<name>PROD1</name>
<password>*****</password>
</group>
<properties>
<property name="hazelcast.heartbeat.interval.seconds">5</property>
<property name="hazelcast.max.no.heartbeat.seconds">300</property>
<property name="hazelcast.master.confirmation.interval.seconds">30</property>
<property name="hazelcast.max.no.master.confirmation.seconds">450</property>
<property name="hazelcast.socket.server.bind.any">false</property>
<property name="hazelcast.jmx">true</property>
</properties>
<map name="rb-*-cache">
<backup-count>3</backup-count>
</map>
</hazelcast>

Do I need to change some parameters (like hazelcast.heartbeat.interval.seconds ?) to increase performance ?

Posted by Srinivas Panyala on 22-Feb-2019 09:03

Please remove below lines from the prod-cluster-conf.xml file. Remove from both the machines and restart both the servers.

<map name="rb-*-cache">

<backup-count>3</backup-count>

</map>

Please remove from cluster-config.xml and master-cluster-config.xml also.

Thanks

Srinivas

Posted by ddessertine on 22-Feb-2019 10:17

I removed it on all nodes and restarted all but still freezing on saving when I have 2 prod in cluster.

Do I need to redeploy WAR files (and remove cache form tomcat) ?

Posted by Srinivas Panyala on 22-Feb-2019 11:20

Could you please log a support case?

Thanks

Srinivas

This thread is closed