String Token of URL for Workflow Action does not work withou

Posted by alank@daitangroup.com on 18-Jan-2018 13:27

I set up an email that has a link directly to a workflow action in its body.

However, the Role that triggers that email does not have permission to run that action, so its string token in the Mail Template is blank, or null.

As a plan B, I'm thinking of linking the Object instead of the action, and then the person manually clicks on the Workflow action in the Object's View Page. However, it would be immensely helpful if we could do it directly to the action.

Posted by Shivani Silveri on 19-Feb-2018 01:19

Hi alank,

Without the permissions, we cannot display the Workflow Action directly.

However, if there is a case of certain condition, based on which the Role can see the action, then, you could give the Permission to that Role and add that Condition in the Workflow Action. Please refer the documentation documentation.progress.com/.../ . Refer to Action Condition Formula in the suggested doc link.

Hope this helps!

Thanks,

Shivani.

All Replies

Posted by Henrique Berenguel on 12-Feb-2018 08:18

.

Posted by Henrique Berenguel on 12-Feb-2018 08:23

.

Posted by Shivani Silveri on 19-Feb-2018 01:19

Hi alank,

Without the permissions, we cannot display the Workflow Action directly.

However, if there is a case of certain condition, based on which the Role can see the action, then, you could give the Permission to that Role and add that Condition in the Workflow Action. Please refer the documentation documentation.progress.com/.../ . Refer to Action Condition Formula in the suggested doc link.

Hope this helps!

Thanks,

Shivani.

This thread is closed