[OpenEdge JDBC Driver] Unable to determine the type of the s

Posted by Wim on 24-Dec-2016 04:14


This message is shown when i try to import records with a articlenumber, price, country and date which is in each record to be red form csv import file.

My object is an articleprice object; this message is diplayed when in this object a Combination of Unique Fields is used as triggertype where articlenumber, country and date are part of. If i change this trigger to only articlenumber and price (so leave out the date) it works fine.

Can anyone help please, thanks in advance

All Replies

Posted by Shiva Duriseati on 03-Jan-2017 03:28

Hi Wim,

Apologies for delay in getting back.

I did following to reproduce the specified scenario:

1)Created three fields integer,text and date.

2)Created Import Map with the .csv file.

3)Created trigger of type "Unique Fields Combination" for above three fieldswhich executes"Before Create" record event.

4)Imported records successfully without any errors.

I ran these test both using MySql and OE databases. But couldn't reproduce.

Please help me further with following information:

1)Have you tried with .xls instead of .csv?

2)Have you migrated from MySql to OE recently?

We ran into similar issue (Unable to determine the type of the specified object)with formula fields which is already fixed in Rollbase3.0

3)Please share app.xml if possible.



This thread is closed