Error on save into an OpenEdge service object

Posted by andrei.cornei on 18-Oct-2016 06:00


I have an object imported from an OpenEdge service object. When I try to save a new record I get the following error:

SAVE-ROW-CHANGES was unable to update the database table <name>. (11910)

I don't have any custom code on the business entity. It is just the default one generated by Progress. The table involved has triggers defined on it. The create one it's just getting the value for primary key. I have commented the rest of the code from the write trigger. Also I tried to use the SkipList from business entity, but it didn't worked.

Does anyone has an idea how to solve this issue?

All Replies

Posted by egarcia on 18-Oct-2016 08:21


There should be other error messages listed along with error (11910).

Please take a look at the log file for the AppServer:

- oepas1.agent.log at the wrk/oepas1/logs folder if you are using PASOE

- restbroker1.server.log at the wrk/ folder for the classic AppServer

These other errors would explain why the update could not be performed. Post them here and I can give you some suggestions.

Note: Setting of the SkipList option ensures that you primary key is set via a trigger. Otherwise, the value that is sent to the server would be used.

I hope this helps.

Posted by Shivani Silveri on 20-Oct-2016 00:53


Can you share the log for that error, its available under Object Definition-> Log



Posted by andrei.cornei on 20-Oct-2016 02:07

Here are the log files.



Posted by egarcia on 20-Oct-2016 05:21

Thank you for sharing the log files.

The oepas2.agent.log shows error (293), (275) and (142).

These errors occur in the create trigger Shoptrigc.p.

The trigger calls getNextObj() which then calls ry/app/rygetnobjp.p but this procedure file is not found, which results on the mandatory Shop field not being set.

You would need to add the dynamics folder to the PROPATH for PASOE so that it can find the procedure file.

You should be able to configure this using PDSOE or directly the file.

I hope this helps.

Posted by andrei.cornei on 20-Oct-2016 07:56

I have added this folder. I got that error after I have changed the propath.

Posted by andrei.cornei on 20-Oct-2016 07:58

I don't get an error in agent log. The error it's directly thrown on UI screen. You can see that in JSDO.log

Posted by egarcia on 20-Oct-2016 10:01


Thank you for clarifying.

The agent.log file shows error (11908) twice, however, it does not have an entry for error (11910) (you original question).

Error (11910) which is being shown in the UI and listed in JSDO.log comes from the server.

The agent.log file does not show entries for the 09:01 mark.

Could you check if there other error messages there?


This thread is closed