problem of installation

Posted by Abir ben salem on 03-Aug-2016 17:02

hi , 

how can I fixe this please , 

All Replies

Posted by Rajkumar Mateti on 03-Aug-2016 23:20

Hi Abir,

if you are really using the certification, Lead and prospect objects in your application then generate application XML adding those objects as Core objects from application definition edit page. If not remove them from Dependent objects of application definition edit page.

Hope this helps..



Posted by abirRR on 04-Aug-2016 01:48

hi ,

I didn't understand how to solve it.

knowing that I need those objects!

Posted by Rajkumar Mateti on 04-Aug-2016 01:58

Hi Abir,

Try with following steps

Before generating the application XML.

1) Navigate to Application settings.

2) Click on Edit button.

  You can find "Core objects" and "Dependent Objects" sections.

4) Remove those object from Selected objects list from Dependent Objects section.

5) Add those objects from Available Objects to Selected objects in Core objects section.

6) Save the application definition.

7) Generate Application XML and then Import application.



Posted by abirRR on 04-Aug-2016 02:49

while installing , I got this error : Cannot create system object with ID -1

Posted by Ramon Schouten on 04-Aug-2016 03:34

Hi Abir,

I think this has to do with you, trying to import an object which isn't in the environment you want to import it in.

For example: you have Certificate listed as a dependent object.

This creates an error if Certificate isn't already in the environment you want to import the Application with a relationship to this object.

Dependent Objects are Objects The Application needs to have installed in the other environment before it can be installed.

Core objects are objects which will be installed with the Application.

For example: If you create a new application based on that xml file, you will have to have all the dependent objects of that application already installed on that environment. If not you will receive an error.

If you make all the dependent objects into core objects it should work.



Posted by abirRR on 04-Aug-2016 04:45

all the dependent objects , I turned it into core object 

see my problem while installing : 

Posted by Ramon Schouten on 04-Aug-2016 05:26


The error you had at the beginning was that you were trying to import the Application, with relationships to 'Certification', 'Leads' and 'Prospects', whilst the application does not contain the Object from where to get these relations.

For short: The Application didn't know where to get the lookup fields or related fields from.

The solution for this is adding them to your dependent or core objects.

Add to core objects if; The object will be used in the Application, but does not already exist on the new environment.

add to dependent objects of; The object will be used in the Application and already exists in the new environment.

If there are no relationships needed with those certain objects, just delete the relationship in the object definition and delete them from dependent and core objects.

These are the requirements for Exporting to XML.

Though, i think you already solved this problem.

If I am right, you now have a problem with importing the XML file to the new environment.

So, you cant install the new application from the XML file.

If you could send an image of the overall install screen (so the image you posted before, but then with the entire page showing) I would have a much better idea of what the actual problem would be.



Posted by abirRR on 04-Aug-2016 05:46

thank you for your response

Posted by Shivani Silveri on 04-Aug-2016 06:14


You are seeing this because, these fields must have been altered/ modified/ used for other purposes in the environment where the app has been built. So, as you try to import into a new tenant, the changes made in the development environment are not present in this.

To solve this, don't select any of the checkboxes and click on Install.

The Installation will be successful.

Hope this helps,



Posted by abirRR on 04-Aug-2016 06:17

I tried without selecting and I got this error ::  Cannot create system object with ID -1

Posted by Shivani Silveri on 04-Aug-2016 06:26

Can you share the details of the version in which the app is developed and in what version of Rollbase its been imported?

Posted by Ramon Schouten on 04-Aug-2016 06:32

I have been trying to recreate this error.

My findings are that the 'Deleted from Application' isn't an error.

They only point out that the version you are trying to import does not contain those fields.

So when checked, they will be deleted when completed. If not checked, they will remain.

Try and figure out if you want to keep those components. If they are no longer needed, check them and see what the result will be now.

This thread is closed