Rollbase 4.2 Private installation with dedicated OpenEdge DB

Posted by KorakSchoone on 29-Jul-2016 07:25


I am experiencing a problem with a clean install from the installer.
I am using the OpenEdge database supplied with the installer and it has been started.

In the log this stack is repeated:

29-Jul-2016 13:59:10.459 INFO [localhost-startStop-1] org.apache.catalina.core.ApplicationContext.log No Spring WebApplicationInitializer types detected on classpath
29-Jul-2016 13:59:12.870 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.loadOnStartup Servlet [Starter] in web application [/master] threw load() exception
java.sql.SQLException: [DataDirect][OpenEdge JDBC Driver]Software caused connection abort: recv failed.
at com.rb.util.system.a582.loadConfigFilesToDb(
at com.rb.master.logics.servlet.Starter.init(
at org.apache.catalina.core.StandardWrapper.initServlet(
at org.apache.catalina.core.StandardWrapper.loadServlet(
at org.apache.catalina.core.StandardWrapper.load(
at org.apache.catalina.core.StandardContext.loadOnStartup(
at org.apache.catalina.core.StandardContext.startInternal(
at org.apache.catalina.util.LifecycleBase.start(
at org.apache.catalina.core.ContainerBase.addChildInternal(
at org.apache.catalina.core.ContainerBase.addChild(
at org.apache.catalina.core.StandardHost.addChild(
at org.apache.catalina.startup.HostConfig.deployWAR(
at org.apache.catalina.startup.HostConfig$
at java.util.concurrent.Executors$ Source)
at Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$ Source)
at Source)

It looks like Rollbase cannot connect to the DB.

In the databases.xml it has the following entry:

<Database name="RB" isDefault="yes" isExternal="no"
MinConnections="3" MaxConnections="10"
MaxInUseConnTimeMins="30" MaxNotUsedConnTimeMins="1"
MaxConnLifetimeMins="60" TxIsolation="2" useTxRecovery="yes">
<Password>  XXXXXXXX  </Password>

All Replies

Posted by Mani Kumar on 29-Jul-2016 07:40

Hi Korak,

This could be possibly a network error because of below reasons :

1. DB is Down

2. Localhost is already used by some other server on network

Can you please try gracefully shutting down Rollbase server --> Stop DB --> manually Start DB --> Start Rollbase and see if this fixed the issue?



Posted by Ruben Dröge on 29-Jul-2016 07:40

Can you connect to the database directly? Or by using a JDBC Query tool using the connection settings you specified?

Posted by KorakSchoone on 07-Sep-2016 03:11


Sorry for the late reply.

Thank you for the replies.

The DB is running fine.

There are no other servers running on the used port.

The login page loads fine, but when I do anything there (login, even change language) I get this error:

HTTP Status 500 - Value of HTTP parameter selLang is too large: 2 chars

type Exception report

message Value of HTTP parameter selLang is too large: 2 chars

description The server encountered an internal error that prevented it from fulfilling this request.


java.lang.IllegalArgumentException: Value of HTTP parameter selLang is too large: 2 chars







note The full stack trace of the root cause is available in the Apache Tomcat/8.0.30 logs.

It is installed op an Windows 8.1 64 bit laptop.

I also tried it on a windows 10 64 bit PC en there it is working fine.

Any suggestions are welcome.

Posted by KorakSchoone on 07-Sep-2016 03:14

In the Tomcat log files I found the following error, which is repeated many times:

Cannot convert the "C:\Progress\Rollbase\pas\bin\Expand.2.0.0.jar" value of typ

e "System.IO.FileInfo" to type "System.Collections.ArrayList".

At C:\Progress\Rollbase\pas\bin\tctailor.psm1:1428 char:9

+         _versions

+         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

   + CategoryInfo          : InvalidArgument: (:) [], RuntimeException

   + FullyQualifiedErrorId : ConvertToFinalInvalidCastException

You cannot call a method on a null-valued expression.

At C:\Progress\Rollbase\pas\bin\tctailor.psm1:1429 char:9

+         _oldversions = [System.Collections.ArrayList]_oldversions.RemoveAt(0)

+         ~~~~~~~~~~~~~~~~~~~~~~~~~

   + CategoryInfo          : InvalidOperation: (:) [], RuntimeException

   + FullyQualifiedErrorId : InvokeMethodOnNull

Posted by Bernard Moeskops on 20-Feb-2017 05:13

Is this issue solved by now? I have the same problem and nothing seems to help. It used to work.

Posted by KorakSchoone on 01-Nov-2017 04:48

Haven't found it yet.

Posted by Ricardo Rafols on 15-Nov-2017 06:10

Hi KorakSchoone,

Checking the error it seems you are starting Tomcat in pas directory instead of Pas_Instance directory.

Another possible issue is the user and password accessing the database.

Using the automatic installer it is always  dbamin/dbadmin

This thread is closed