Send Email Trigger

Posted by on 05-May-2016 02:25


How can I control the "sent from" e-mail address?

For some reason every time it is sent from another user.

Attached is a screenshot of the log emailing.
I want e-mail will be sent from specific address.



All Replies

Posted by Vasantha on 05-May-2016 03:10

Hi Tehila,

Follow the below documentation to change the "From" email address.



Posted by on 08-May-2016 06:00

Thank Vasantha but I think this is not provide a solution to the problem... The same user geting the same Email some times from one email, and some time from enother one.

Would love your help.



Posted by srikanth kasavajhula on 16-May-2016 07:17

Hi ,

Can you send me a screenshot of your email server settings ?

Posted by on 17-May-2016 07:29

I am one of the user of rollbase. I believe you only have control on reply to email address. From is always the email address of the logged in user email address. I am also not able to change the From.

Posted by Vasantha on 23-May-2016 02:11

Hi Tehila,

Follow the below steps and let me know whether you are able to change the 'From' email address.

Go to Email Server Settings.This page enables you to set up and test custom email server settings for all users in your tenant

1. Select 'Use Following Email Server' to set up custom email server settings.

By default, 'Use Default Settings' is selected, which uses the email server settings set by the administrator of the master tenant.

2. Edit the following custom email server settings: Host Name, Port Number, Encryption (select None if your email server is not enabled for SSL & TLS encryption), User Name (Email ID), Password (Email password), and a default Auto-Reply Address.

This email address is used for all email communication in your tenant.

For example, if you have set as your custom email address, and if a user in your tenant, with email address, creates an email trigger to communicate with your clients, then your clients receive an email from as opposed to

To allow your users to communicate using their email addresses (in the previous example,, you must select the Allow Per User Account check box. After this check box is selected, all the users in your tenant can configure their personal email from their Personal Setup page.

3. Test your email server settings by specifying a sample email address and then clicking Test Settings to see if a sample email message is received at the specified email address.

A pop-up dialog appears, if the message was received successful, select 'Message Was Received in Mailbox' to enable the 'Save' option else reconfigure your email server settings and try again.

4. Click Save.



Posted by on 06-Jun-2016 05:55

Hello Vasantha! 

Thank you very much for your answer! 

I tryed this,

and got this error...

hope you can help me.




Posted by Vasantha on 06-Jun-2016 06:04

Hi Tehila,

Try changing the port to 465 and smtp user to gmail id.



Posted by Ruben Dröge on 06-Jun-2016 06:27

No leave the port as is (587), make sure you use TLS and use (instead of just

Of course you need a valid gmail account & password.

Posted by Karthikeyan Bhaskaran on 06-Jun-2016 06:31

Change the value to This should solve the problem even if port is 587 (TLS required).

If you continue testing with port 587 the screenshot would have the following:







And, the "Connection Test" email would have been received by the recipient.

Hope this helps.

Posted by on 07-Jun-2016 03:55

Thanks for the this! 

I tried this and it didn't worked...

Posted by Vasantha on 10-Jun-2016 03:40

Hi Tehila,

Can you please select the 'Encryption' as 'TLS' and try?



This thread is closed