[V4.0.4.0] - Workflow Action Button not rendered

Posted by IramK on 11-Apr-2016 06:10


I have a workflow action button that was visible based on some condition and it works fine with the condition. However when I comment out the code and save the workflow action button configuration, the button is still not displayed. When I actually delete the code completely from the condition section, only then the workflow button is displayed. This seems like a bug to me and would like to know if someone can confirm this issue.



All Replies

Posted by Nitin Kumar Singh on 11-Apr-2016 06:40

Hi Iram,

This is so because when you comment out the whole code, we evaluate the result of the condition as false in absence of any explicit return true. Thus, Action is not being rendered. There is a new functionality being introduced in 4.2 - a simple check-box (Enable Formula) on all such Boolean returning formula pages.

So, in case your formulas is still not complete, you can keep on editing but just un-check the above check-box, before saving. This way, formula is not evaluated until you are ready for it.



Posted by IramK on 11-Apr-2016 06:48

Hello Nitin,

Thanks for that. That looks like a great enhancement and definitely would help us going forward. V4.2 gets more and more lucrative as we get closer to the release date. May I ask as to when exactly is V4.2 due to release?



Posted by Nitin Kumar Singh on 11-Apr-2016 06:55

Hi Iram,

Glad you are excited about our upcoming release. Right now 4.2 is planned to release on Apr 30th (2016).



Posted by Thierry Ciot on 12-Apr-2016 21:35


Please give it a try on the EAP instance to confirm it works as expected.


Posted by IramK on 13-Apr-2016 04:48

Hello Thierry,

Thanks for asking me to confirm it. Unfortunately it doesn't work as expected. When I check the "Enable Formula" I would expect the buttons not to be there using the formula given below but they are still shown:

var currentRecord = {!id};

if(currentRecord > 0)
  return false;
  return true;

Also the positioning of workflow actions has moved back to the dropdown list, however currently in 4.0.4 we have the workflow actions position next to the "Next", "Previous" and "Back to list" button. This is not where we were expecting it to be. This can be easily seen in the Default CRM application -> Cases -> View Page.


Posted by IramK on 20-Jun-2016 06:14

Hello [mention:e5d6fd9a1d9042a6a3c7b20e0f22c213:e9ed411860ed4f2ba0265705b8793d05],

I have just updated to version 4.2 and I don't see the Enable Formula button anymore in this release. It is however still available in the EAP. I thought this was implemented a while ago?


Posted by Anoop Premachandran on 23-Jun-2016 09:01

we did not release it in 4.2 due to issues in backward compatibility found while testing. We will roll it out in an upcoming release.

Posted by IramK on 23-Jun-2016 09:13

Is that going to V4.3? Any updates on the release date for that?


This thread is closed