User permission

Posted by shilpi.agarwal3373 on 22-Jan-2016 02:36

Hi All,

I have created an application named "myapp" and created one object "Title". Then add User role and then User account with name "Demo Dutt". After that I have created a new tab named  "appmembers" and tab type is "Object" and then select object "User".

When I logged in as demo dutt user name with login name and password (which i received form Progress email), I am not able to see the "appmemebers" records. but i am able to see titles record.



Please suggest

All Replies

Posted by Manooj Murali on 22-Jan-2016 02:47

Hi -

Can you please check if the user's ( "Demo Dutt") role had access to user object.


Posted by Mani Kumar on 22-Jan-2016 02:50

Yes Manooj, even if the user has the permissions to the user Object, the view doesn't list user records.

Posted by Mani Kumar on 22-Jan-2016 03:08

Looks like an issue for me.

Even after providing permissions on all objects and views (= Administrator), still the user is not able to view the records.

Posted by Srinivas Panyala on 22-Jan-2016 03:08

Please check "myappview" View permissions once. Provide view permissions for this user role.

User Object definition -> Views -> Click on Permissions link of "myappview"



Posted by Srinivas Panyala on 22-Jan-2016 03:21

LDF permission is enabled by default for the User object. Please set Location, Department & Function for User object records. Then you can see the records.

Please read the following documentation for more details about LDF permissions



Posted by shilpi.agarwal3373 on 22-Jan-2016 04:54

Following steps are performed to set LDF permission-

1. Create a record in Location, Department and Functions in Organization Management.

2. Create a Group named "MyGroup".

3. Assigning users to this group.

4. Enable the Organization attribute for User Object on both the application "Organization Management" and "Myapp".



Still not able to see the appmembers  in "Demo Dutta" user when i logged as Demo Duuta".

Please suggest or specify the steps for setting LDF permission.

Posted by Srinivas Panyala on 22-Jan-2016 05:05

Please follow the below steps:

1) Login as Admin

2) Navigate to User object

3) Click on edit record (which record you want to display for non-admin user-Demo Duuta)

4) Click on design this page (Page Options -> Design this page)

5) Drag and drop the fields Location, Department & Function from left panel to page

6) Click on Save and Synchronize

7) Now select same values as you selected for "MyGroup" and save the record

Now login as Non-Admin (Demo Duuta). You should able to see the above record you edited



This thread is closed