Clear Search button click issue - New UI

Posted by IramK on 21-Jan-2016 06:37


I have a contact object and have a detailed search component in order to search for a Contact on the record list view page. Clicking on search and cancel on this works fine. In another application, I have a relationship with contacts and have a tab for contacts called "secondary contacts". In here as well I have a detailed search component with different search criteria than the other detailed search component (described above). When I click on search using this new criteria, I do get to the search results page, however when I click on "Clear Search" it takes me back to the first detailed search component and not the current one where I performed my search. This seems like a bug to me as it should go back to the detailed search component where I did my search. Could someone please confirm to me if this is a known issue?



All Replies

Posted by Mani Kumar on 21-Jan-2016 06:53

Hi Iram,

I tried this on the latest version on Public cloud. The search and clear works fine for me on the second object.

I've an Application say X and has Object Contact. I configured detailed search on this and this works fine.

Now on another application say ApplicationY, I've Object B, which is related to Contact Object on ApplicationX.  Created a Tab for the contact Object as secondary search.

Configured detail search with criteria as Object B equals, tried to search and it works fine. Clear too works for me.

Are all  of these native objects ?



Posted by IramK on 21-Jan-2016 06:59

Sorry there is no relationship with contact in Application Y. Its just a contact object tab. Could you check it without having a relationship please? And these are not native objects.



Posted by Mani Kumar on 21-Jan-2016 07:12

Okay, I've removed the relationship and retried. It still works for me.

Posted by Mani Kumar on 21-Jan-2016 07:13

What version are you on?

Posted by IramK on 21-Jan-2016 08:01

Version 4.0.4. Not sure why it is behaving like this.

Posted by IramK on 21-Jan-2016 08:44

However I have deleted the tab now and added it back again and it works fine. Its quite weird that it did not work earlier. I had exported this app from 4.0.2. earlier and imported it in 4.0.4. Do you think that would've caused this issue?



Posted by IramK on 25-Jan-2016 09:57

Hello [mention:ce2116fd258e46ee8b4509379c9663a4:e9ed411860ed4f2ba0265705b8793d05],

I have been able to reproduce this bug many times now. Basically every time I create a new tab with a new detailed search component, it creates a new record list in the list of pages. And no matter where I create the tab, it always takes me back to this record list page. Existing search components also take me to this record list page. This I think is a bug. Could you please confirm to me that this is what is happening?



This thread is closed