Issue with rbf_setFieldValue for lookup field - 4.0.4.

Posted by IramK on 12-Jan-2016 11:15


I have been using the standard rollbase function rbf_setFieldValue() for setting a lookup's field value and I have noticed a bug with it. Basically whenever I try to set the field value, it sets the field value correctly. However if I set the same field value again, it appends to the select list in the DOM and upon trying to save this record the form errors out saying that the value was not specified for that field. Could someone please provide an alternative solution for this?

Relationship type: M - 1. The 1 side of the relationship is for the lookup field.



All Replies

Posted by jsniemi79 on 12-Jan-2016 11:21

Have you tried clearing the value first before you set it?

Posted by IramK on 12-Jan-2016 11:26

Yup, tried it. Did not work.


Posted by jsniemi79 on 12-Jan-2016 12:44

Can you post a sample of your code?

Posted by IramK on 13-Jan-2016 03:09

Its quite simple actually.

rbf_setFieldValue("integrationName1", 1005); // ID of the record = 1005

rbf_setFieldValue("integrationName1", 1005); // Another setFieldValue with the same ID



Posted by IramK on 13-Jan-2016 03:50

I have reported a very similar issue here:

Can someone confirm to me if this has been fixed in 4.0.4.?



Posted by Vimalkumar Selvaraj on 16-Feb-2016 22:54


This issue is fixed and targeted for 4.0.6



This thread is closed