[4.0.4] rbf_setFieldValue() Error

Posted by Meryk on 23-Dec-2015 04:41


I am on a QC page and I have a picklist field lets call it Type. So depending on the value of Type I am showing and hiding fields. And also making the shown fields required.

I am also emptying the fields I want to hide before hiding them. The issue here is I am doing : rbf_setFieldValue('intName' , null); for all the fields I need to hide.

These fields are all lookups, rendered as selectors and picklists. One of these fields is a multi relationship, but it is behaving the same for all the fields.

The problem is that I keep having this :

Also, setting the fields to null is working fine, the fields are emptied correctly. But the error is still there.

I tried with only one field and same thing, so I am assuming the type of relationship doesn't have any effect here..

Can please someone give me some help with this? I had exactly the same code in 4.0.2 and didn't have this error before.

Thank you,


All Replies

Posted by Meryk on 23-Dec-2015 05:34

I am having this same error in other places :

Here is the scenario this time : I have a lookup field on a QC page that I am making required through code, not in RB. I removed all onchange events of that field. When I select a value for that field and remove it after that I am getting the same error as above.

Is there validation running on change of the field ? so because it is required, as soon as I empty it, and before clicking on Save I get this error ? Or is there any other reason for this error?



Posted by Mohammed Siraj on 23-Dec-2015 08:02

Yes Meryem, on setting a field value via API we also fire validation for that field.

This was done starting Rollbase 4.0.4 release as fix for an issue reported by Iram stating that on setting field value of a required field via API, validation errrors still exist .

This thread is closed