Many to one relationship selection issue - New UI

Posted by IramK on 01-Dec-2015 08:30

Hello,

I have two objects (A-B) related to each other in a many-to-one relationship(A: Many, B: one). When trying to create a record A with B's lookup field selector being there and selecting the same B record twice (by mistake or knowingly), this append multiple options of the same record in the DOM for B's lookup field and now when I try to save record A, it errors and says that B's value is empty.

This is reproducible quite easily on the Quick Create page because the pop up for the selector doesn't close when a selection is done. However, this can be reproduced on the New and Edit Page as well by selecting the same record multiple times.

Could someone confirm to me if this is a known bug? Kindly let me know.

Version: 4.0.2.0

Cheers.

Iram

All Replies

Posted by Rajkumar Mateti on 01-Dec-2015 09:13

HI Iramk,

Yes, it is an issue. We will log a defect and let you know once its fixed.

Thanks,

Rajkumar

Posted by Karthikeyan Bhaskaran on 01-Dec-2015 09:15

I could see this problem in the new UI.

This was my test:

Many-to-one relationship between object A and B, lookup for B, and the field is set mandatory

Select the same record of B, twice.

If the field is not set mandatory, then I could save the A record, with empty value for B.

Posted by IramK on 01-Dec-2015 09:22

Exactly, those are the two scenarios. Could this be fixed in the December release please as this one would be quite important. Kindly let me know.

Cheers.

Iram

Posted by IramK on 13-Jan-2016 03:49

I have posted another similar issue here: community.progress.com/.../78559

Posted by IramK on 13-Jan-2016 03:49

Has this been fixed in 4.0.4.?

Iram

Posted by IramK on 29-Jan-2016 09:16

Hello guys,

Could someone let me know if this issue has been fixed or not please?

Cheers.

Iram

Posted by Vimalkumar Selvaraj on 16-Feb-2016 22:53

Hi,

This is fixed now and targeted for 4.0.6.

Thanks,

Vimal

This thread is closed