Field level validation - Lookup selector - New UI

Posted by IramK on 05-Nov-2015 11:19


I have posted this question earlier when this issue was there on the old UI i.e. with relation to the fact that field level validation did not work when comparing the value of a lookup selector field. Could someone confirm to me if this has been fixed or not in the New UI? I have still been facing the same issue in the New UI. Kindly let me know.



if("{!R66128}" == "")
      return "Value is required!";

// where R66128 is the lookup selector field

All Replies

Posted by Rajkumar Mateti on 05-Nov-2015 11:50

Hi IramK,

I tried the same scenario but the validation is working fine for me. Can please confirm the following is what you are facing the problem.

1) Create object A

2) Create Object B

3) Create relationship between A and B(Many A to One B)

4) Created Validate record data trigger as follows


               return "must have VAL";

   R7126 is the relationship integration name

5) When i try to create a record in A without having a value for B look up its giving the message saying  "must have VAL"

Note: Its working fine even if i modify the relationship name. Let say R7126 to "RelatedRel" and used {!RelatedRel} in formula.

Can let us know iwhat exactly you are trying if this is not what you are trying.



Posted by IramK on 06-Nov-2015 05:59

Hello Rajkumar,

Thanks for your answer. I have tried the scenario above and can confirm that yes it does work properly however after carrying out some proper testing I noticed that this issue is reproducible when the relationship is a hierarchy. Could you please try the above test with object A in a parent child relationship and apply the validation on the child and let me know if you can reproduce it.


Posted by IramK on 09-Nov-2015 06:20

Hi Rajkumar,

Any luck with finding this issue? Kindly let me know.


Posted by Rajkumar Mateti on 09-Nov-2015 06:29

Hi IramK,

Yes, Its an issue. Thanks for catching it.

We logged a defect.



Posted by IramK on 09-Nov-2015 06:32

Would it be possible to get this fixed in the december release please?



Posted by IramK on 10-Nov-2015 03:57

Hello R Rajkumar,

Now that we know that this doesn't work, could you possibly provide me with an alternative client-side validation that I could use to validate that field? I will remove the server-side validation on this field in the meanwhile.

Also could you please let me know when I could expect this to be fixed.



Posted by Chandrasekhar Gontla on 10-Nov-2015 05:37

Hi Iram,

Could you please try "Treat this trigger as a Warning: user may choose to ignore it and proceed further" option which is in trigger definition.

You could submit the form by ignoring incorrectly generated error message.

Please let me know whether it is working for you.

Thanks and Regards,


Posted by IramK on 10-Nov-2015 05:43

Hello Chandu,

But this is not a viable solution because if the user doesn't select a value and ignores the warning then we do not have a value for a field that is required. Any other possible solution using kendo ui validation may be?

Kindly let me know.



Posted by Aede Hoekstra on 11-Nov-2015 08:36

Hi Iram,

Why don't you use the setting on the field level:  "Always require a value in this field in order to save a record"?

Posted by IramK on 11-Nov-2015 08:59

Hello Aede,

Thats because the requiredness of that field is based on a condition.

So if another field's value is set, then I would like to make this field as required and then carry out my validation.

Posted by Pradeep Kagithalagudem on 12-Nov-2015 01:03

Hi Iram,

Use Custom field validation. Refer this link

Go to page 67 in above pdf file.

Thanks and Regards


Posted by Pradeep Kagithalagudem on 12-Nov-2015 01:07

Please ignore my above post.

Thanks and Regards


This thread is closed