Upgrading to new UI for rollbase (Urgent)

Posted by anu31221@gmail.com on 23-Aug-2015 05:19

After I login to rollbase, I have got notification to upgrade to new UI. I have upgraded for all users.

UI looks great, but version stop working. When login from mobile device, its taking to below page and its giving error

https://www.rollbase.com/prod1/b/newui/mMain.jsp

Error:

404: The page you have requested does not exist or has been moved.

If you continue to see this message please Contact Us.

Go to www.progress.com 

Needs your urgent help.

1. How can we fix this issue

2. Do we need to revert back the account to older version? if yes then how to revert back.

3. Do I need to update all views to work with new UI?

Regards

Anurag

All Replies

Posted by psaradhi on 23-Aug-2015 06:18
The issue is happening only through mobile or Rollbase portal as well?

Pardha.
Thread created by anu31221@gmail.com

After I login to rollbase, I have got notification to upgrade to new UI. I have upgraded for all users.

UI looks great, but version stop working. When login from mobile device, its taking to below page and its giving error

https://www.rollbase.com/prod1/b/newui/mMain.jsp

Error:

404: The page you have requested does not exist or has been moved.

If you continue to see this message please Contact Us.

Go to www.progress.com 

Needs your urgent help.

1. How can we fix this issue

2. Do we need to revert back the account to older version? if yes then how to revert back.

3. Do I need to update all views to work with new UI?

Regards

Anurag

Stop receiving emails on this subject.

Flag this post as spam/abuse.

Posted by Thierry Ciot on 23-Aug-2015 08:18

We need to look into the 404 issue.

In the meantime, you can go back and forth between classic ui and new ui.

Go to Setup Home

In administration Setup: click Preferences

Uncheck New UI Setting

Posted by murali on 23-Aug-2015 13:53
Anurag,
                The Settings  (Setup Home >  Administration Setup  >  Preferences)  allow you to  upgrade
 
1) Just For Youself   ( recommended while you try it out )
2) For select users
3) For everyone ( Not recommended until you have tested your app in NUI well )
 
So we recommend that you turn it on just for yourself in the initial days while you test your app in NUI.
There is no per – View upgrade. The NUI rendering will render the entire app in the new way.
 
We are looking a providing a fix for the mobile device pages ASAP.
 
 
[collapse]
From: anu31221@gmail.com [mailto:bounce-anu31221gmailcom@community.progress.com]
Sent: Sunday, August 23, 2015 6:21 AM
To: TU.Rollbase@community.progress.com
Subject: [Technical Users - Rollbase] Upgrading to new UI for rollbase (Urgent)
 
Thread created by anu31221@gmail.com

After I login to rollbase, I have got notification to upgrade to new UI. I have upgraded for all users.

UI looks great, but version stop working. When login from mobile device, its taking to below page and its giving error

https://www.rollbase.com/prod1/b/newui/mMain.jsp

Error:

404: The page you have requested does not exist or has been moved.

If you continue to see this message please Contact Us.

Go to www.progress.com 

Needs your urgent help.

1. How can we fix this issue

2. Do we need to revert back the account to older version? if yes then how to revert back.

3. Do I need to update all views to work with new UI?

Regards

Anurag

Stop receiving emails on this subject.

Flag this post as spam/abuse.

[/collapse]
Posted by anu31221@gmail.com on 23-Aug-2015 14:17

This issue heppening only where try to login from mobile(www.rollbase.com/.../mMain.jsp)

404: The page you have requested does not exist or has been moved.

If you continue to see this message please Contact Us. - See more at: community.progress.com/.../19760.aspx

Posted by Rajkumar Mateti on 24-Aug-2015 10:28

Hi Anurag,

Can you check it  now, its fixed.

Thanks,

Rajkumar

Posted by anu31221@gmail.com on 24-Aug-2015 15:35

Yes, its fixed.

Please let me know where y want me to send other defect which I found in new UI.

E.g 1 View selection, you have to refresh the page to load the data for a view.

Posted by Anoop Premachandran on 24-Aug-2015 21:31

Please log a new thread with details here. Also share the browser and OS versions and steps with Screenshot.

Posted by Thierry Ciot on 24-Aug-2015 22:01
Additionally, give it a try in chrome browser (if not already what you are using), bring the dev tools ( CRTL Shift I ), click network tab, click XHR, change view, you should see an Ajax request, please post the request and response from the dev tool (you can copy text from there).
 
[collapse]
From: Anoop Premachandran [mailto:bounce-apremach@community.progress.com]
Sent: Monday, August 24, 2015 10:32 PM
To: TU.Rollbase@community.progress.com
Subject: RE: [Technical Users - Rollbase] Upgrading to new UI for rollbase (Urgent)
 
Reply by Anoop Premachandran

Please log a new thread with details here. Also share the browser and OS versions and steps with Screenshot.

Stop receiving emails on this subject.

Flag this post as spam/abuse.

[/collapse]
Posted by Aede Hoekstra on 25-Aug-2015 04:21

Hi Rajkumar,

We also facing this problem on our private cloud, is there also a fix available for the private cloud? Looks like there are some files missing in the installation.

Regards,

Aede

Posted by Anoop Premachandran on 25-Aug-2015 05:11

We will be shortly releasing a service pack for Private Cloud as well that fixes this issue.

Posted by Aede Hoekstra on 25-Aug-2015 05:13

Thanks for the info Anoop,

This thread is closed