All new Contacts created appear in Search results

Posted by ByronB on 15-Jun-2015 06:24

Hi there

We have come into a situation where all new Contact records created are showing up when performing a search on the Contact's List view page. We have set the search criteria to Fist Name OR Last Name OR EmailAddresses (linked Object).

We are not using a record name template for the Contact object as we are populating it manually based on the Prefix First Middle Last combinations.

Indexing is selected for all the fields as well as reindexed. Can anyone point me in the right direction here?

All Replies

Posted by pvorobie on 15-Jun-2015 10:28

And what do you search for? Please provide more info.

Posted by Aede Hoekstra on 15-Jun-2015 10:28

There was a problem with reindexing. (which was solved in Rollbase version: 3.2.0)

You can also check the search log, then you can see what is searched and which id's are retured.

Posted by ByronB on 15-Jun-2015 10:35

We have a Detailed Search component on our List view for Contacts:

Hosny Someone and BB BB are new contacts, if I search First Name = Dave the new Contacts are also appearing in the Search Results page:

Posted by ByronB on 15-Jun-2015 12:43

Hi Aede

Where would I find the search log? I have looked everywhere I can think of but can't seem to find it :-/

Posted by Aede Hoekstra on 16-Jun-2015 02:40

Hi Byron:

Go to: Administration > Global text search

Posted by ByronB on 16-Jun-2015 08:34

Hi mate, I do not seem to be getting anything returned for the searches I am doing:

[2015-06-16 10:14:56,139] Add index: objDefId=6324 id=544850

[2015-06-16 10:36:00,217] ==> Start reindexing all documents for licenceDetail

[2015-06-16 10:36:00,249] --> Finished reindexing all documents for licenceDetail: 4 total

[2015-06-16 10:36:00,264] Reindex object: objDefId=541022

[2015-06-16 12:56:38,034] Update index: objDefId=519029 id=519361

[2015-06-16 12:56:39,722] Update index: objDefId=519029 id=519361

[2015-06-16 12:56:39,768] Update index: objDefId=519029 id=519361

[2015-06-16 12:56:40,565] Update index: objDefId=519029 id=519361

[2015-06-16 12:56:40,565] Update index: objDefId=519029 id=519361

[2015-06-16 12:56:40,581] Update index: objDefId=519029 id=519361

[2015-06-16 12:56:45,050] Update index: objDefId=519029 id=519361

[2015-06-16 13:53:43,364] Update index: objDefId=19349 id=31596

[2015-06-16 13:54:00,395] Update index: objDefId=19349 id=31596

[2015-06-16 13:54:04,098] Update index: objDefId=19349 id=31596

[2015-06-16 14:11:28,005] Update index: objDefId=19349 id=31596

[2015-06-16 14:17:45,771] Update index: objDefId=19349 id=31596

[2015-06-16 14:18:17,834] Update index: objDefId=19349 id=31596

at the time of testing it was 2015-06-16 14:32

Posted by Orchid Corpin on 16-Jun-2015 11:17

Have you not seen any entry like "Search: query=" ?

I tried searching in Global search and in detailed search, so far I have this entry in my search log after I did the test.

[2015-06-17 00:09:38,584] Search: query=kidd AND defId:26928 objDefId=26928 Results:

[2015-06-17 00:11:27,065] Search: query=corpin AND defId:50031 objDefId=50031 Results: 634511,71962

Posted by ByronB on 16-Jun-2015 11:23

Hi Orchid

On the global Search I got a hit on the Search log but not for the detailed search:

[2015-06-16 17:16:26,339] Update index: objDefId=519029 id=541542

[2015-06-16 17:22:17,777] Search: query=dave objDefId=0 Results: 49615#99

[2015-06-16 17:22:25,324] Update index: objDefId=542009 id=544541

Posted by Orchid Corpin on 16-Jun-2015 11:30

Hi Byron,

Sorry for the confusion, yes I am not getting search entry in logs too when using detailed search, I thought I have because I was using the same keyword. I'll confirm first if this is an expected behavior.



Posted by Orchid Corpin on 16-Jun-2015 12:11

Hi Byron,

I just confirmed from our dev team that this an expected behavior, as an explanation to this "Global Search goes via Search Engine. Detail Search & Filter are for more complex search criteria and is handled via SQL".

When you use global search does it return the expected result?



Posted by ByronB on 16-Jun-2015 12:27

Hi Orchid

Yes if I use global search I get the expected result. Even when doing a Details Search on another object I get expected results. Its very strange behavior.

The only thing that has changed for our Contact object is how we populate the Contact Name field:

Cleared out the Record Name template (We populate it manually)

Name field is used on the New and Edit forms with a modal popup to fill in the Prefix, First Name, Middle Name & Last Name which in turn populates the contact name field (on hiding of the modal).

If the users type directly into the Name field we build up the possible combinations to populate the actual Prefix, First name, Middle Name and Last Name fields that are hidden on the form.

No I do not see how this could be related at all but it is the only customization I have done on Contacts of late.

On double click or clicking the edit icon:

Posted by Orchid Corpin on 16-Jun-2015 17:54

I don't think if the customization is causing it either where we are searching for a saved record.

Can you try to disable save > then enable again field property "Index this field as part of the text search engine."?



Posted by ByronB on 17-Jun-2015 03:12

Hi Orchid

Thanks for the input but whether indexing is checked or not the results are the same using the detailed search :-/, is Indexing only relevant for the global search or is it for detailed search as well?

Posted by Orchid Corpin on 17-Jun-2015 13:41

This is for global search only, I'm just trying some options related to searches. BTW what version it this?

Is it okay if can you attach here a copy of a test xml with this object?  I'll investigate further.



Posted by ByronB on 18-Jun-2015 06:33

Hi Orchid, we are running 3.2

Is there a way to export a specific object or would I have to generate the XML for the entire application?

Posted by Orchid Corpin on 18-Jun-2015 10:11

Hi Byron,

you can create a new app > Create from existing objects > Specify the object needed and tab. After saving you can generate the app with that object, if there are dependent objects specify it too but in the core objects since I don't have those dependent objects pre-installed.



Posted by ByronB on 18-Jun-2015 10:58

That would mean basically exporting our entire database lol as Accounts & Contacts are linked to pretty much everything. Can we not rather give you access?

Posted by Orchid Corpin on 18-Jun-2015 11:05

I see, so don't export it. I suggest to create a support ticket so we can investigate it further and we can share files and info privately.



Posted by ByronB on 18-Jun-2015 11:05

ok great, thanks

Posted by ByronB on 19-Jun-2015 03:54

Hi Orchid, i registered for support but my client ID was not recognized but was able to submit the application regardless.

I have not been able to actually create a ticket as yet

This thread is closed