Percent field appends a comma and moves the decimal

Posted by IramK on 12-Jun-2015 05:24

Hello,

I have a percent field that I am using to display percentage. If I input 17.5 as my percentage on a new record, when I go back in to edit the record, it changes it to 175,00%. Is that expected behaviour? I'm performing certain calculations based on this field and I wouldn't have expected it to change the percentage. Also how can I use dots instead of commas in that percent field? Kindly let me know.

Cheers.

Posted by IramK on 15-Jun-2015 06:08

Ok I figured out what the issue was. The settings were stored in "My Localization Settings" and not under "Settings -> Localization Settings" which is where I was getting confused. Changing that to the desired setting made it work.

Thanks.

All Replies

Posted by Manooj Murali on 12-Jun-2015 06:03

Hi -

Which version of rollbase are you on?

If on 3.2, is the localization settings set for the tenant/user?

   If yes, what is the setting for Number Format?

If no, can u paste the screenshot of the percent field edit page?

-Regards,

Manooj

Posted by IramK on 12-Jun-2015 06:38

Yes I am on version 3.2 and the localization settings are set for me (Administrator). The number format setting is: 12,345,678.12.

Posted by Tom Kincaid on 12-Jun-2015 08:23
 
As an FYI, I tried this on the public cloud just now and it seems to work fine.
 
 
[collapse]
From: IramK [mailto:bounce-IramK@community.progress.com]
Sent: Friday, June 12, 2015 7:40 AM
To: TU.Rollbase@community.progress.com
Subject: RE: [Technical Users - Rollbase] Percent field appends a comma and moves the decimal
 
Reply by IramK

Yes I am on version 3.2 and the localization settings are set for me (Administrator). The number format setting is: 12,345,678.12.

Stop receiving emails on this subject.

Flag this post as spam/abuse.

[/collapse]
Posted by IramK on 15-Jun-2015 03:56

It still doesn't work for me for some reason. Any luck on finding the issue or a solution please?

Posted by Manooj Murali on 15-Jun-2015 04:46

I cannot seem to reproduce this in my environment as well. Do you have a hosted cloud account where the issue is reproducible?

Posted by IramK on 15-Jun-2015 06:08

Ok I figured out what the issue was. The settings were stored in "My Localization Settings" and not under "Settings -> Localization Settings" which is where I was getting confused. Changing that to the desired setting made it work.

Thanks.

This thread is closed