Triggers chain is terminated to protect shared system resour

Posted by matman on 20-May-2015 02:37

Hello,

I have 2 triggers that genereate objects using the rbv_api.createRecord function from Rollbase. After working for a couple of days, it currently doesn't work anymore. The tiggers throw the following errors: Triggers are running for 1432039385450 ms. 300000 ms max is allowed. Triggers chain is terminated to protect shared system resources. But the triggers are never stoped or something like that. The next time I call the triggers the same error is thrown, but with the same amount of ms that the triggers are running, so again 1432039385450. 

What can I do to solve this problem?

Thanks in advance

All Replies

Posted by Godfrey Sorita on 20-May-2015 09:26
Hi Matthijs,

rbv_api.createRecord() runs after create triggers on the target object. Depending on the number of records created and number of "After Create" triggers on the target object, the execution time for 1 trigger can go this high.

You can prevent the execution of "After Create" triggers by using "Create New Record" triggers instead. There is a setting in the trigger to "run dependent Triggers after this one is
completed". Simply uncheck the property and record creation should execute without running the triggers.


Regards,
Godfrey
Posted by matman on 21-May-2015 04:32

Hello Godfrey,

Thanks for your response. Removing on create triggers on the created objects did the trick. What is strange is that it worked for a while, and then just stopped, without changing anything on the triggers. Any idea why this could be?

But main thing is I got it to work, so thank you!

Regards

This thread is closed