How do I stop a lookup from preloading

Posted by ByronB on 28-Jan-2015 13:08

Hi guys, I have looked everywhere but can't seem to find out where to disable a lookup preloading on a new form. As an eg When we create a new Contact the Account field is preloaded with the last visited Account, I understand why it would behave like that but we dont require it.

Probably somewhere simple but I cant for the life of me find it

Posted by Orchid Corpin on 28-Jan-2015 15:40

Hi Byron,

Try to remove the Account Lookup from the form then save. Now edit the page again and specify the Account lookup to the form then save. It works for me, I think this is just some cache issue.

Regards,

Orchid

All Replies

Posted by Orchid Corpin on 28-Jan-2015 13:30

Hi Byron,

Here are steps that clears the default values of a lookup.
1. Go to object definition > Edit the lookup field > clear the Default Value (if there is a value assigned to it)

2. Go to New/Edit page and click Design this page > Open Lookup properties and uncheck the "Use Record in Scope for New Objects" and "Show Record In Scope" (Show Record In Scope usually disabled - only enabled when a lookup is a hidden style)

Hope this may help.

Regards,
Orchid

Posted by ByronB on 28-Jan-2015 13:38

Hi mate


Just to show you as I would have thought the same:



and the field definition:





[collapse]
From: Orchid Corpin <bounce-ocorpin@community.progress.com>
Sent: 28 January 2015 19:31
To: TU.Rollbase@community.progress.com
Subject: RE: [Technical Users - Rollbase] How do I stop a lookup from preloading
 
Reply by Orchid Corpin

Hi Byron,

Here are steps that clears the default values of a lookup.
1. Go to object definition > Edit the lookup field > clear the Default Value (if there is a value assigned to it)

2. Go to New/Edit page and click Design this page > Open Lookup properties and uncheck the "Use Record in Scope for New Objects" and "Show Record In Scope" (Show Record In Scope usually disabled - only enabled when a lookup is a hidden style)

Hope this may help.

Regards,
Orchid

Stop receiving emails on this subject.

Flag this post as spam/abuse.

[/collapse]
Posted by Orchid Corpin on 28-Jan-2015 13:41
Yes, that is exactly the pages.

Regards,
Orchid
Posted by ByronB on 28-Jan-2015 13:43

ha ha but as you can see there is nothing being used in scope and no values have been defaulted?

Posted by Orchid Corpin on 28-Jan-2015 13:46

Do you have any code to the page that possibly setting the lookup?

Regards,

Orchid

Posted by ByronB on 28-Jan-2015 13:48

Nothing mate, I did try clearing it out On Load of the form but seems counter productive.

Posted by Orchid Corpin on 28-Jan-2015 13:58

When you create a new Contact, is it from a Workflow Action or a New Contact from the contact list view page?

Regards,

Orchid

Posted by ByronB on 28-Jan-2015 14:12

We are not running workflow for that object mate. It doesnt matter how I load the New Contact form the same behaviour happens:

I have a button that fires the following code:

<form>

<a id="cp-new-accountcontact" class="btn btn-primary" style="display: block" onclick="self.location='dev.internal.applicationscloud.codelessplatforms.com/.../main.jsp Account & Contact</a>

</form>

As well as if I click the New Contact button in the List of Contacts, so it would see as though it is set on the page itself but there is nowhere in my code that I am doing it (Although I am working with the behavior).

Posted by Orchid Corpin on 28-Jan-2015 14:25

Hi,

Can you send me a copy of the xml of your app that includes that object to ocorpin@progress.com, I think the above configurations are the only options to clear the lookup aside from code.

I would like to check if this is a possible defect so I can report it to the development team.

Regards,

Orchid

Posted by ByronB on 28-Jan-2015 14:32

Email sent

Posted by Orchid Corpin on 28-Jan-2015 14:59

Hi,

I already received the email. Will now check the app.

Regards,

Orchid

Posted by Orchid Corpin on 28-Jan-2015 15:40

Hi Byron,

Try to remove the Account Lookup from the form then save. Now edit the page again and specify the Account lookup to the form then save. It works for me, I think this is just some cache issue.

Regards,

Orchid

Posted by ByronB on 28-Jan-2015 16:15

Thanks, worked. Should have tried that...

Posted by Orchid Corpin on 29-Jan-2015 08:40

That's great that it works for you!

Cheers,

Orchid

This thread is closed