Wrong decimal-sepearator

Posted by smartsysISV on 23-Dec-2014 13:57

Grid show 'dot' as decimal separator, even if the fields decimal-seprator is set to .comma'.

Is there anyone else experiencing the same error?


All Replies

Posted by Orchid Corpin on 23-Dec-2014 14:18


Tested in grid and it seems it displays comma - working as expected.

1. Created a new Decimal field

2. Set Decimal separator to Comma

3. Place field to grid and try to enter a value

4. Save, noticed in list view and edit of grid it displays e.g. 2 000,00

Can you provide your steps to replicate if ever I missed something?



Posted by Chandrasekhar Gontla on 24-Dec-2014 01:40


I too tried the same case in rollbase.com and it is working fine for me.

Couple you please provide exact scenario where you found the issue?

Thanks and Regards,


Posted by smartsysISV on 24-Dec-2014 01:46

My setup is similar to what Orchid describes.

But i use a calculation to set this field, ex:

var calcpp=Math.round((antx*parseFloat(ppfactor)*100))/100;

rbf_setGridValue2(0,"palletspace", radno, calcpp)

Posted by pvorobie on 24-Dec-2014 11:45

API rbf_setGridValue2() does not perform any additional formatting. It just sets value you provide to HTML text box. So if you need additional formatting (such as setting decimal separator) please add this formatting to your JavaScript.

Posted by Orchid Corpin on 24-Dec-2014 11:56

Have you also tried creating another decimal field with comma as separator, and see if it has the same issue?



This thread is closed