Rollbase 3 issue - can't run pas after installation

Posted by protutor on 12-Nov-2014 04:01

Hi, I have installed OE 11.4 and RB 3.0.5 with PAS on Win7 64-bit.

I am trying to run RB first time. Admin service is running, rb db is on. When run tcman start command I am getting message: ..netia.com can't find... Non-existing domain.

Using CATALINA_BASE ....

Using CATALINA_HOME ....

.........

Any help is very appreciated,

piotr

All Replies

Posted by Manooj Murali on 12-Nov-2014 04:19

Can you please post the complete console output ?

-Thanks

Posted by protutor on 12-Nov-2014 04:45

Here you are,

Thank you

Posted by Michael Jacobs on 12-Nov-2014 05:17

During its startup PAS will try to resolve the full DNS name of the system, and set it as a property that can be used by the web applications.   It does the DNS lookup using the Windows 'nslookup' command, which is what displays the message you are seeing when a DNS server is not available.  While distinctly ugly, the message has so far has not been seen to affected the PAS server's ability to start/stop.   But there is always a first time.

You can uncomment two lines in the bin/setenv.bat file if you want to test to see if the nslookup error is preventing the server from starting.  Comment out the following two lines and then try to start the server again:

   for /f "tokens=2 delims=: " %%i in ('nslookup %COMPUTERNAME% ^| findstr "Name:"') do set _dnsinfo=%%i

   set JAVA_OPTS=%JAVA_OPTS% -Dpsc.as.dns.name=%_dnsinfo% -Dpsc.as.host.name=%COMPUTERNAME%

Note: This message will be suppressed in later PAS versions and the system's IP address used when a DNS server is not available.

Let us know how this works.  If the server still does not start we may require the catalina.<date>.log and localhost.<date>.log files.

Posted by protutor on 12-Nov-2014 09:20

Still nothing but this message from lookup is gone. I attach catalina.out from OE 11.4 workdir. The 2 logs you asked for are not created.

Posted by Michael Jacobs on 12-Nov-2014 11:45

I can see from the catalina.out file that a mixture of different servers is going on.   There are references to the debug version of a Tomcat server used with the OpenEdge development studio product, and references to a PAS instance in your Rollbase installation.  The very first line "Executing Tomcat operation version" is from running the "protc" utility, which is not involved in any administration of Rollbase or the Rollbase PAS instance.   Somehow you are mixing two incompatible severs: OE development Tomcat and Rollbase PAS.

Just for clarity, you are entering the command:

   d:\Rollbase3\Pas_Instance\bin\tcman.bat start

You can see the primary configuration of the Rollbase PAS server by using:

   d:\Rollbase3\Pas_Instance\bin\tcman.bat env

The definitions for CATALINA_HOME & CATALINA_BASE should be in d:\Rollbase... , and you should not see references to d:\OpenEdge114\servers\tomcat.

Posted by protutor on 12-Nov-2014 12:56

Yup, I noticed that and don't know why it is. Please see commands I enter.

Posted by Michael Jacobs on 12-Nov-2014 14:00

Did the logs get created in d:\Rollbase3\Pas_Instance\logs  ?   You also would have a window with a title PAS-Pas_Instance.

Posted by Orchid Corpin on 12-Nov-2014 14:20

Can you try creating a new "Environment Variables" for those with "Using"?

Like Variable Name = JRE_HOME

Variable value = C:\Program Files (x86)\Java\jre7 (or wherever are these located in your machine)

Do the same to the others, CATALINA_HOME, CATALINA_BASE, etc.

Hope this may help.

Regards,

Orchid

Posted by protutor on 12-Nov-2014 14:43

I created those variables at the beginning but as nothing was better deleted them. I may try again.

The log files are still not created.

Posted by Michael Jacobs on 12-Nov-2014 15:32

From the tcman1.jpg image all of the CATALINA_HOME & CATALINA_BASE were the expected paths.  (The CATALINA_HOME and CATALINA_BASE environment variables are already custom tailored in the Pas_Instance to point to the correct installed location)

The command line is also what I would expect to see.   So it is puzzling why no log files are generated - although I have seen this if catalina is exiting very early before the logs are created.

You can try using the d:\Rollbase3\Pas_Instance\bin\startup.bat  command, but I expect that it will shed no additional light on why the Rollbase server will not start.   And without logs, it is hard to debug though a forum.

Posted by protutor on 13-Nov-2014 04:42

Yes, I'll log a request in techsupport. Thank you for your contribution.

Posted by Michael Jacobs on 13-Nov-2014 05:47

Sad we couldn't get you running by discovering something simple.

The following three commands will gather additional information that you can passalong to help technical support and engineering:

d:\Rollbase3\Pas_Instance\bin\tcman.bat version

d:\Rollbase3\Pas_Instance\bin\tcman.bat test

d:\Rollbase3\Pas_Instance\bin\tcman.bat config

The first shows the versions of the server and Java, the second runs a kind of server startup sanity check, and the third dumps the entire server configuration (assuming you have not manually edited server.xml).

Posted by protutor on 13-Nov-2014 11:28

Thanks. I will add this to the req.

Posted by protutor on 13-Nov-2014 11:39

When I run tcman test there is an Error message: This Java instance does not support a 64 bit JVM.

Please install the desired version.

Maybe the issue lies here.

Posted by Michael Jacobs on 13-Nov-2014 13:40

That error message would be consistent with no log files being generated - the server exited before log files were opened.

This thread is closed