Public URL to test Mobile Apps

Posted by jsniemi79 on 29-Oct-2014 14:39

I am running Rollbase Mobile from a private cloud instance.  I want to send the URL for the mobile app I am building to another user, but regardless of the setting for public/private URL, it is forcing the user to the appdesigner Login for Progress.

The test url from the copy function is this: 

https://appdesigner.rollbase.com/app/mobile-frame?src=https://appdesigner.rollbase.com/app/view/5cc22f0e-1987-4fe1-842e-e17deade8229/MyPhoneApp.html&type=mobile&size=320x480

Am I missing something?

All Replies

Posted by Anil Kumar on 30-Oct-2014 03:37
When the Test URL is opened in any of the new browser session,  Yes it will prompt for the valid (any) Progress ID credentials to validate the Progress session (as we are accessing appdesigner). Once the credentials are validated Mobile Emulator is shown to user.
 
Following are set of ways for sharing the mobile app to other users:

1)      Download the specific mobile app as a zip file and host it under a WAR file in any of the webserver. There is an option available in RB Private cloud to download the mobile app

2)      Share the mobile app test URL which requires Progress ID credentials before launching mobile emulator)

3)      We can also add specific user through ‘Administration Setup’ section

 
Note: There is also another option named ‘Mobile Hosting’ which is specific to Rollbase hosted cloud, where we can host mobile app to a (given) Rollbase domain
 
Thanks and Regards,
Anil Kumar.
 
[collapse]
From: jsniemi79 [mailto:bounce-jsniemi79@community.progress.com]
Sent: Thursday, October 30, 2014 1:10 AM
To: TU.Rollbase@community.progress.com
Subject: [Technical Users - Rollbase] Public URL to test Mobile Apps
 
Thread created by jsniemi79

I am running Rollbase Mobile from a private cloud instance.  I want to send the URL for the mobile app I am building to another user, but regardless of the setting for public/private URL, it is forcing the user to the appdesigner Login for Progress.

The test url from the copy function is this: 

https://appdesigner.rollbase.com/app/mobile-frame?src=https://appdesigner.rollbase.com/app/view/5cc22f0e-1987-4fe1-842e-e17deade8229/MyPhoneApp.html&type=mobile&size=320x480

Am I missing something?

Stop receiving emails on this subject.

Flag this post as spam/abuse.

[/collapse]
This thread is closed