Issue with expression (decimal) field

Posted by Aede Hoekstra on 17-Oct-2014 04:55

I have a problem with an expression field of the type decimal. I can't change the format. So the default decimal separator is a .  (dot) Because we're in the Netherlands the customer wants a , (comma) as decimal separator. 

But I'm not able to change it, also when creating a new field this isn't possible. As a (temporary?) work around I use a decimal field with the right display format and let a trigger fill this field. But that shouldn't be the way i guess..

All Replies

Posted by Manooj Murali on 17-Oct-2014 06:11

I created a customer whose base language I set as Dutch. Now, I login as the customer, created an expression, the decimal format shows up right (i.e. no dots but a comma). see attached screenshot.

Am I missing something?

Posted by ymaisonn on 17-Oct-2014 06:13
Hi Aede,

I have created defect with ID PSC00316820 in our bug tracking system for this issue.

Regards

Yannick
Posted by Manooj Murali on 17-Oct-2014 06:26

Hi Yannick,

Please outline the steps for reproducing the issue. I presume the base language for the user was set to dutch.

-Thanks

Posted by ymaisonn on 17-Oct-2014 06:54

Here are the steps to reproduce:

1- Create a regular "Decimal" field

> separator: , (comma)

>default value: 123,45

>integration name "decimalfield"

2- Create a formula field

> return type "decimal"

> return value: {!decimalfield#value}

Observe that the field reads "123.45" on the record View page

Setting the language to "Dutch" has no effect

KB article: knowledgebase.progress.com/.../000054681

Posted by Aede Hoekstra on 20-Oct-2014 02:50

Thanks Yannick and Manooj!

Posted by ymaisonn on 30-Oct-2014 05:29
Hi Aede,

This issue has been addressed: Engineering has added separate column which will allow to chose the decimal separator. For rest of the types this column is disabled.

The changes are expected to be visible in Rollbase 3.1

Regards

Yannick
This thread is closed