Customizing customer and subscriber creation

Posted by ithrees on 18-Aug-2014 08:04

Hi All,

How/Where the first subscriber/admin user creation is linked with the customer/tenant creation in System Console application as I need few customization in this?

Thanks and  Best Regards, 

All Replies

Posted by Orchid Corpin on 18-Aug-2014 09:15
Hi ithrees,

If you are looking for the customer creation page, this can be found in the Customers tab and click on the New Customer.
Once you are in the new customer page you can customize it through "Edit this page" link in the right most part of the tabs section.

Regards,
Orchid
Posted by Orchid Corpin on 18-Aug-2014 09:22
More customization can be found in the Object Definition of Customer object where you can add triggers, workflows, templates, etc.
Posted by ithrees on 18-Aug-2014 12:10

Thank you Orchid,

In this case I am trying to automate the customer creation process with an application. In this app when the workflow status is changed to a certain value that record need to be converted as a customer. I managed to get this done up to a level that converts the record as a customer record but it is not creating its subscriber/first admin user even though I am correctly mapping the email, last name and login name details.

I just want to figure out the issue by understanding the customer creation process. Hope you would get my point.

Regards

Posted by Orchid Corpin on 19-Aug-2014 17:25
Hi ithrees

Yes, I get what you mean and tested in my test environment too and get the same issue that after creating the Customer from data map of objectABC it does not create a first admin subscriber. Will try to get more info in the development team whether this is possible or is there a way to get the desired customization.

Regards,
Orchid
Posted by Orchid Corpin on 02-Sep-2014 11:56
Hi ithrees,

I've talked to one of our developer and this seems to be a bug, will file a defect for this.
Any application / XML that is related to this feel free to send it over for further investigation? (send to: ocorpin@progress.com)
Also what Rollbase version are you using? I tested this in the release 3.0.2 (latest) also failed to create a first admin.

Regards,
Orchid
Posted by Orchid Corpin on 04-Sep-2014 13:04
Hi ithrees,

This has been fixed and will be expected in the 4.0 release.
Thank you.

Regards,
Orchid
Posted by ithrees on 17-Sep-2014 07:28

Hi Orchid,

Yes, I tested this on 3.0.2 as well and failed. Good to hear that its been fixed.

My application is a simple user registration app that will convert a record into a customer when the process is completed. Hope I can extend my application with this feature in future release.

Thanks and Best Regards,

Ithrees

Posted by Orchid Corpin on 17-Sep-2014 09:14

It was said to be working before in master zone, good thing you saw this issue since only few clients are using this.

Will keep you posted about this.

Regards,

Orchid

Posted by Orchid Corpin on 25-Nov-2014 16:52
Status Update: Defect PSC00312926 was fixed for version RB 3.1.0.0 and will be released this December 6, 2014.
Date specified is a tentative date and may subject to change.

Regards,
Orchid
This thread is closed