Rollbase codepage

Posted by mihai_neagoe on 17-Jul-2014 07:56

Hi,

We have a couple of oe service objects imported in Rollbase. The codepage used in OpenEdge is ISO8859-1 for database, appserver. The problem is that when using french caracters in Rollbase these characters are displayed in a different codepage.

Is it possible to set the codepage in Rollbase to ISO8859-1? The problem we are having is that the database codepage is ISO8859-1 and I would avoid the conversion to UTF-8 if possible (already in production).

All Replies

Posted by Gian Torralba on 17-Jul-2014 09:56
Hi Mihai,

May I know what database server are you using in your Rollbase private instance?

Thank you,
Gian
Posted by mihai_neagoe on 18-Jul-2014 01:36

Hi Gian,

The Rollbase repository is on a OpenEdge database as well. It has a ISO8859-1 codepage.

Mihai

Posted by Bill Wood on 18-Jul-2014 07:50
In the next version of Rollbase the embedded OpenEdge DB will install with UTF-8 as the character encoding, but as Mihai says, it is ISO-8859-1 in Rollbase 2,2 and earlier.
Posted by mihai_neagoe on 29-Jul-2016 03:22

Hi,

Same question on upgraded environments. We have a 4.2 RB version and a 3.2.4 version in place. Both versions have an OpenEdge Object in place which connects to the same service.

Version 3.2.4 displays the correct formatting:

While version 4.2 displays the incorrect formatting:

Is there a codepage setting in 4.2 that can be added?

The only difference I see is that the 4.2 environment has a rollbase database that has been upgraded from 3.0 using the incremental files and the 3.2.4 is a installation from scratch using the installer.

Thank you,

Mihai

Posted by Anoop Premachandran on 02-Aug-2016 14:11

Can you try version 4.2.1 ? In 4.2.1 we fixed issue with handling UTF-8 characters for sendJSONRequest method.

We use sendJSOnRequest internally to query OpenEdge Service object

See www.progress.com/.../release-4.2.1

Just FYI - the latest version is 4.2.2, So better to download that.

This thread is closed