RED FLAG: Import/Installation from Rollbase XML

Posted by Ryan Canja on 16-Jun-2014 01:38

Hi Guys,

I'm having a problem with Import from Rollbase XML application installation. I encounter this issue since my XML reached 10+MB in size. Here is the scenario:

1. Rollbase engine version is the same from source to target.

2. There was no problem encountered during XML generation.

Problems encountered after successful installation:

1. Some pages are missing. Sometime, certain object has no edit page or insert page.

2. One more triggers were not included/missing after installation in one or more objects.

3. One or more objects are missing

Impact in our production

1. Every time we deploy the app in a new zone, we always do a regression test to double check which component was not loaded during the installation. 

2. Since our application is big, an enterprise type in scope, regression test eats a lot of time in my production.

3. Finally, we can't implement a self service/on the fly zone creation by registering online for our customers.

Can somebody help us or advise us the best practice to solve this problem? Hoping for your prompt response.

Thank you in advance.

All Replies

Posted by Laurent on 16-Jun-2014 14:56

To move this forward we would need to have a look at the XML file so we can reproduce the problem. If you have a SupportLink account, I would suggest that you file a support case and attach the XML to the case.

Posted by Anoop Premachandran on 19-Jun-2014 07:46

Can you share the Rollbase version your are using ?

Posted by Ryan Canja on 19-Jun-2014 23:33

Hi Anoop,

We are using a 4.08 version.

Posted by Anoop Premachandran on 20-Jun-2014 03:34

Since Progress acquired Rollbase, we have reset version to 1.0 and we have released many versions since then. The current release is 2.2.2.0. We had fixed issues related to import/export of large data in 2.1 and 2.2 releases. Please upgrade to the latest release and this issue should be fixed.

Posted by Ryan Canja on 20-Jun-2014 04:22

Thanks for your reply, but can you please specify what solution/fixed you did specifically for export/import of large data? I did not read that in any of your release notes. Also, we have another application with similar size of file, running in 2.0.0.4 engine version, still the same problem we encountered.

Posted by Anoop Premachandran on 20-Jun-2014 07:59

We had olut of memory issues with large datasets

Posted by Ryan Canja on 22-Jun-2014 20:03

Another fuzzy answer.

Anyone from Rollbase team can help us with this?

Posted by Tom Kincaid on 23-Jun-2014 04:33
Hi Ryan,
 
There have been many changes and improvements in this area around optimizing the parsing of XML and the usage of memory. So it is hard to point to a particular change that would likely fix this issue. Are you unable to go to a more recent version of Rollbase?
 
 
 
[collapse]
From: Ryan Canja [mailto:bounce-ryancanja@community.progress.com]
Sent: Sunday, June 22, 2014 9:03 PM
To: TU.Rollbase@community.progress.com
Subject: RE: [Technical Users - Rollbase] RED FLAG: Import/Installation from Rollbase XML
 
Reply by Ryan Canja

Another fuzzy answer.

Anyone from Rollbase team can help us with this?

Stop receiving emails on this subject.

Flag this post as spam/abuse.

[/collapse]
Posted by Santosh Patel on 23-Jun-2014 04:38

Hi Ryan,

We did fix certain things around backup/restore of actual data as opposed to the metadata Rollbase XML, which is what Anoop was referring to. Regarding import/export of Rollbase app as XML, we have a couple of customers whose XML stretches to around 17-19MB and the import works fine for them (verified).

It would be really helpful if we could investigate on your application XML as suggested by Laurent above.

Regards,

Santosh

Posted by Ryan Canja on 23-Jun-2014 05:05

Hi Santosh,

Sent the file through the support link for your investigation, case # is 00279453 for your reference.  

I hope you can provide us your findings soonest possible.

Thanks,

ryan

Posted by Santosh Patel on 23-Jun-2014 05:15

Checked the support case. Don't see any attachments, could you confirm if it got uploaded?

Posted by Ryan Canja on 23-Jun-2014 05:22

Attached. Recheck pls. Thanks!

Posted by Santosh Patel on 23-Jun-2014 05:26

Got it. 4 applications. Thanks.

could you point to the app that has problems? Also some verification points to check if the import was proper. Is something missing all the time?

Posted by Ryan Canja on 23-Jun-2014 21:41

Yes, always something is missing and it's very inconsistent that's why everytime we do installation we required our QA team to do an end-to-end regression tests. It might happen in any of the apps. Extraction of XML has no problem as well as installation but when you check it, sometimes there is no edit/new page in one or many objects, quick create page is missing, missing triggers, etc.

Posted by kbachtold on 24-Jun-2014 10:22

Hi Ryan,

We are a private cloud customer in RollBase, with five applications, the largest is 7.7 MB.  I have noticed with really large applications the log is not properly generated for application update because of parameter "MaxHTTPParamLength" (in shared.properties).  It seems when the application finishes installing, the log parameter is passed as an HTTP parameter to the logging component.  Since the default is 80,000, the contents of your application install log is likely much larger and so failing to log.

If you adjust this parameter MaxHTTPParamLength to a larger value like "1,000,000", then retry the install, you should be able to see detailed logging of the install process in "install.log" file on the affected customer.  (I would recommend reducing the value back to the default of 80,000 after installation completes successfully).  The logging output can sometimes help in troubleshooting why some components did not install properly.

You may also want to check that the missing components are actually present in the source XML file.  The Application XML is fairly human-readable and you can search for pages/triggers by name and make sure they are present in the extracted XML.  Generally we've not had problems with our 7 MB application installing correctly with all components.

Hope this helps,

~ Kurt

Posted by Ryan Canja on 25-Jun-2014 04:41

Hi Kurt,

Thank you for your response. We will explore the adjustment of MaxHTTPParamLength to see the actual/complete logs. As for the XML file, yes, we have checked it. Actually, before you install the app, it will populate a tree view of  all your object configurations, we have checked it as well and there's no missing items. It only happens after installation.

Thanks!

Posted by Ryan Canja on 03-Jul-2014 20:52

Hi Santosh,

May I follow the findings from your team about the file I gave you? Case # is 00279453 for your reference. We tried to upload the same file using the 2.2.0.0 version, but still the same problem we encountered. Below are the details of the issues:

1. Missing views with filters (with own object) - checked object and their relationship in the imported xml and found it; object was also found in UI

2. Filters are detached upon xml import.

3. Some records cannot be saved even if all fields are filled-up - checked all hidden fields and found no required fields.

"Error: Invalid data. Review error message below to correct your data."

4. Found some validations in the app that are not working, but functions in the original version

5. Found some triggers in the app that are not working, but functions in the original version

Thanks!

Posted by Ryan Canja on 10-Sep-2014 01:30

This problem has not solved since reported!!!

ROLLBASE TEAM,

Please help. Please attend to report Case No. 00279453.

Posted by Mani Kumar on 10-Sep-2014 01:33
Hi Ryan,
 
I have posted a workaround on case that worked for me.
 
Can you please check.
 
Thanks and regards,
 
Mani Kumar V V
This thread is closed