Odd behavior of logging in PASOE 11.7.5 (for msagent)

Posted by dbeavon on 26-Sep-2019 23:12

Something is really odd about ABL agent logging in 11.7.5.  

For one thing it broke the ability to dynamically change logging levels while the PASOE instance is running. See:




However, there are other weird things going on as well.  Consider this logging configuration.



For whatever reason, the new behavior of the agent for that configuration is to generate 4GLTrace output at logging level *2*.

It appears that whatever new programming work was done between 11.7.4 and 11.7.5 in the area of ABL logging has caused more than one problem.  It broke several things at the same time.  (I only wish that we were able to get some benefits out of the new programming work, rather than just the bugs).

My theory is that there is no such thing as "4GLTrace" for logging level 1.  So the properties system is trying to be smarter than me and is "coercing" the logging level up to 2 in order for the output to appear in the logs.  However, this is not how it worked in the past.  Previously we were able to simply switch the logging level between 1 and 2 in order to include or exclude the 4GLTrace output.  In other words, I'd rather that the system would "coerce away" the 4GL tracing output at logging level 1 like it used to, and pretend that I had not requested 4GLTrace as one of my log entry types.

Has anyone else upgraded to 11.7.5 yet and experienced these types of issues?

All Replies

Posted by Fernando Souza on 27-Sep-2019 13:25

Tthe fact that log entry types are getting turned on with logging level 1 is a bug. Please, report it to Support.

Posted by dbeavon on 18-Oct-2019 16:31

I'm still fighting with PASOE over my msagent logging level. I had worked with Progress support and they mentioned a possible workaround for any logging related issues.  They had said some things broke when "deferred logging" was introduced ... and claimed that things would go back to working the old way by setting a new property ("defrdlogentrytypes") to have a blank value.



But this still doesn't totally seem to be working. When new agent processes are started, they launch with the wrong level and immediately start flooding the log files - even at level 1 (because the msagent logging behaves like it is set to level 2).

Since that normal logging level property doesn't seem to work as expected (red arrow in image), I've started embedding my preference of logging level into the "log entry types".  This can be done with the colon syntax, and that it seems to take effect as one would expect (highlighted below in yellow).  

Hopefully this helps others who are upgrading to OE 11.7.5.  Ideally this will go back to working properly again, but that might not happen until OE 11.7.6.

This thread is closed