Unneeded Errors in Sonic Adapter Logs

Posted by shiggins on 26-Sep-2018 13:51

I was trying to diagnose errors when printing reports and came across an issue with NameServer not being about to connect to Sonic Adapter. I got this same error (displayed below) multiple times after changing various port numbers for the adapter and NameServer with no luck. I then stopped PASOE, SonicMQ, and the full AdminService and restarted all. I was still getting the same error about the port, but I found this, and it turns out the full reset worked:


And it turns out this isn't a "real" error and it should just be ignored. Why is this being printed to the logs? This is documented, starting 3 years ago, as not affecting the ability of brokers. Do these error messages just never get removed?

[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- Unhandled exception while dispatching messages
[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- java.lang.IllegalArgumentException: port out of range:-1
[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- at java.net.InetSocketAddress.checkPort(InetSocketAddress.java:143)
[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- at java.net.InetSocketAddress.<init>(InetSocketAddress.java:188)
[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- at java.net.InetSocketAddress.<init>(InetSocketAddress.java:166)
[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- at com.progress.ubroker.debugger.DebuggerWorker.startServer(DebuggerWorker.java:468)
[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- at com.progress.ubroker.debugger.DebugServer.doStartServer(DebugServer.java:273)
[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- at com.progress.ubroker.debugger.StartServer.run(StartServer.java:27)
[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- at com.progress.ubroker.debugger.DebugSession.dispatchMessages(DebugSession.java:69)
[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- at com.progress.ubroker.debugger.DebuggerWorker.dispatchMessages(DebuggerWorker.java:217)
[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- at com.progress.ubroker.debugger.DebuggerWorker.mainline(DebuggerWorker.java:126)
[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- at com.progress.ubroker.debugger.DebuggerWorker.run(DebuggerWorker.java:82)
[18/08/28@09:15:48.673-0400] P-002320 T-Broker debugger 1 UB ----------- at com.progress.ubroker.debugger.ubDebuggerThread.run(ubDebuggerThread.java:80)

All Replies

Posted by dbeavon on 26-Sep-2018 14:00

That level-1 UB error message ("port out of range: -1") doesn't mean anything.  You are supposed to ignore it. You can tell this is the case if you just read the message ...  ie. an "Unhandled exception" means you don't have to handle it in any way. ;-)

Posted by Matt Baker on 26-Sep-2018 14:24

There should be a bug logged for this, but the  KB article you linked to doesn't reference one.  The debugger functionality in the unified broker shouldn't be attempting to start (even if it isn't actually enabled) for anything other than appserver and webspeed.

Please call tech support and have them log a bug for this so this noise in the log file can go away.

Posted by Srinivas Munigala on 27-Sep-2018 04:36

There is a bug#PSC00244440 already logged for this issue and fixed in 12.0.0

This thread is closed