SSL Errors Connecting to Webservice

Posted by nix1016 on 11-Jul-2018 21:31

I'm having some issues connecting to webservices requiring SSL on a clients server running 11.6.3 using the standard connect command:

hSocket:connect('-H <host> -S <port> -ssl')

I get the error:

Secure Socket Layer (SSL) failure. error code 29712: SSL routines (9318)
Connection failure for service HTTPS host <host> transport TCP. (5483)

Progress knowledgebase says it's an issue with the protocol/cipher but I've tried adding the correct protocol and cipher to the connection string based on the article which has not worked. I've also tried setting the protocol in windows environment variables to no avail.

I've tried using the sslc utility in proenv and that seems to connect ok. It's just when using the connect method that gives me the error on webservices requiring SSL. FWIW, I've only tested on TLSv1.2/SSLv3 websites (can't find any using TLSv1.1 or below) so not sure if it's the protocol, but I thought 11.6.3 should cater for TLS1.2 anyway?

Any ideas on what else might cause the problems?

All Replies

This thread is closed