Trying to connect to running db in progress explorer

Posted by Robert Cohen on 04-Jul-2018 08:34

working through the progress OpenEdge tutorial and running progress explorer to connect to sports database.  I have create a new copy of the sports 200 database and it is running in multi user mode.  when It  set up the Database migration utility in Progress explorer it setup fine but does not connect to the sports database I created.

If I click on the "Start database" it say it is running in multi user mode - How you I set the connect up in progress Explorer to connect in Multi user mode?

If I click on the "Start Agent" after trying it just times out - any help apprecitated


All Replies

Posted by James Palmer on 04-Jul-2018 08:40

If I'm reading you correctly, the issue is that the database was started by some means other than the explorer, so explorer isn't aware it's already running. Am I right?

If so, then you'll want to first shut down the database.

Assuming you're running on Windows, start the proenv tool, and navigate to the physical location of your sports2000 database. In that directory run "proshut sports2000 -by".

Give it a little for the database to shut down, and then in progress explorer try starting the database again.

If I'm barking up the wrong tree, could you please give a bit more background, such as OS, Progress version etc, and try and redescribe the problem.

Posted by Robert Cohen on 04-Jul-2018 09:23


Thanks for this but it did not work - I shutdown the database using the proenv - cd to the /wrk/db directory where the sports db is located and ran proshut sports -by and this worked

I then tried clicking on the "Start Database" in the Progress Explorer tool and after a while it just timed out

I am running the latest classroom edition of Progress - OpenEdge 11.7 (64-bit) on windows.

 I am not sure what is starting the database automatically - but something in the setup as going through the tutorial - they are always running when PC reboots. 


Posted by James Palmer on 04-Jul-2018 09:33

So the database is located in c:\openedge\wrk\sports?

(By the way, on a proenv session, you can run 'prompt' to see the folder you're in, just for future reference).

It would be helpful to see a screen shot of the configuration screens for your database in explorer.

As an aside, if you would rather start and stop your databases using a script then shout - you do not have to use Progress Explorer.

Posted by Robert Cohen on 04-Jul-2018 09:44


I am aware of scripts starting - old Unix 8.3 and now Linux 11.3 but trying to learn all this new stuff in windows and following the tutorial and it is not working out

Not sure what configuration screes you want but here are some


thanks for the continued help


Posted by James Palmer on 04-Jul-2018 09:49

The Auto Start is probably what's causing the DB to start when you restart the computer.

Maybe I'm misunderstanding what the problem is?! Quite possible!!

Are you trying to start the database, or are you trying to connect to a running database? If the latter, for what purpose?

Posted by Robert Cohen on 04-Jul-2018 10:56


I am trying to work through the "OEDK_Tutorial_Getting_Started_OpenEdge 11.7.pdf" tutorial and on pages 30 though 33 it talks about using Openedge Explorer to add a database so that it is managed by Explorer (can be managed).  when I follow the instructions I get the database setup but it is not list as running as shown in the example in the tutorial and I cannot get it to that state using Openedge Explorer - as below


My databases do not show as running even through they are and I cannot get them to "be registered" in the Explorer tool and then next section of the tutorial deals with "connecting a database to a project" and I am not sure if I can do that with out the database showing as running


Posted by Robert Cohen on 04-Jul-2018 10:59


Not sure if the pictures were inserted - attached now

Posted by James Palmer on 05-Jul-2018 02:23

Those last pics are from the manual, right?

Ok so try and start the database again from the explorer and first of all see if you get anything in the DB log file. c:\Openedge\wrk\sport.lg

If not, go to c:\openedge\wrk\admserv.lg and see what is in there. That last one gets quite noisy, but you will see it's trying to do something, and probably more detail on the errors in question.

Posted by Robert Cohen on 05-Jul-2018 09:49


I looked at the logs and one message occurs in all continually.  so to get a clean look what is did was manually shutdown the sports and the oebpsdev databases and then stopped the admin server proadsv -stop and renamed all the log files

I then rebooted the PC to get a clean start point and the Adminservice started and the admsrvc.exe process and two _mprosrv.exe processes

I then check all three logs and looks like things all came up correctly - but in the admsrv.log - there was one issue trying to restart something on port 20931 which was already assign earlier - but not the issue I am sure.

I then started Progress Explorer and tried to start the database as suggested and it return a message about running in multi user mode -  so I used proenv and manually shut down the database.  I then tried to start the database using Explorer and it ran for a long time but checking the logs the database came up quite quickly.  Eventually the Explorer start process timed out and it still say it is not running - see logs attached

The only thing I can see is that fathom is trying a different port but I am not sure it is the same thing.

Could it be similar to running fathom to connect to my production Linux server where I cannot use it to manage the server as that are not started using nsman but started with proserve


P.S. the lack of the Explorer start did not store developer studio from finding the database.


Posted by James Palmer on 05-Jul-2018 10:08

So Dev Studio and the Explorer are not in any way linked - so you will be able to continue as you say.

The issue looks, from the logfiles, to actually be a problem with the Admin Service, rather than the databases. I think the databases are starting up fine, but they're not reporting back to the admin services that they've started. Seems all a little bit odd to me.

Do you have multiple Progress versions installed on the machine?

Have you changed anything in the admin service configuration at all?

To be honest, my first step for solving this would be to uninstall and reinstall Progress and see if that solves it.

Posted by Matt Baker on 05-Jul-2018 10:50

A knowledge base search turns up this: 000019474

Indicating you have a DNS configuration conflict with your hostname.

You're running 11.7.0.  You should install 11.7.3.

At the very least it will clean up the CONTENT SECURITY POLICY REPORT warnings in the log file.

The "The operation completed successfully" coming out of the database broker has been there for a very long time.  It indicates a problem connecting to the adminserver when started as a managed database.  

Is this a laptop?  

Can you post the ads0.exp file (from same location as admsrev.log file)?   This has full stacks for the error messages which might give a clue as to what is failing.

Posted by Robert Cohen on 05-Jul-2018 11:29


Thanks once again for the help.

I do not have a hosts file - or at least one that is being used - all info is commented out

I am not sure what this has to do with DNS as it is all running locally on the PC

As to the version I only have what came in the Classroom version witch was a complete package of progress version 11.7 - file was - which one would presume if Progress is putting out as a teaching / learning / class room version it should work

the ads0.exp file is attached


Posted by Matt Baker on 05-Jul-2018 11:37

The ads0.exp file indicates the RMI failed to create the necessary adminserver bindings in the local RMI registry.  Probably because something else was/is using port 20931.

This caused all sorts of other stuff in the adminserver not be setup properly, including the database plugin which is why you are getting timed out messages about database not connecting.

  Exception at Tue Jun 26 16:19:01 EDT 2018: java.rmi.ConnectException

  Message (throw): RegistryManager: Bind failed

  Message (excp):  Connection refused to host: RCOHEN-2016; nested exception is: Connection timed out: connect

  Stack Trace:

java.rmi.ConnectException: Connection refused to host: RCOHEN-2016; nested exception is:


Posted by Robert Cohen on 05-Jul-2018 14:27


My network guy came in and we review what we had done and what was running etc.  He felt it was McAfee causing the problem - we checked the McAfee Firewall Event Logs and it was blocking the java.exe program - once we added an exception for this things started to work - I then shutdown everything and brought it all up clean and brokers, agents, and App server all stated to show up and log files and other familiar files in the WRK directory, Progress Explorer now show the databases running and the App server , named server, web server, and web speed are all running.  Making me much happier

I think I am good for now - thanks for the help


Posted by James Palmer on 06-Jul-2018 03:36

Really good to hear you got it sorted. Those pesky antivirus programs eh?

Less of an issue for simple tutorial following, but I would make sure you exclude the directory you'll keep your databases in from the antivirus program if at all possible. Antivirus can lead to performance, and even integrity issues in certain circumstances. Less of an issue for development of course, but it's still a hassle.

This thread is closed