Getting error 8839 - but do i deserve it ?

Posted by S33 on 05-Apr-2017 14:06

In a test setting, we are getting error 8839 "No SQL servers are available. Try again later." trying to connect to a 10.2b dev database on RHEL 7 via jdbc. There were no problems accessing the database when the java was local, but we moved it to an amazon hosting environment. Ports are open and there is communication going on, but the database doesn't connect. I am able to odbc from a local Windows and pull data into excel for example.

The "no SQL servers available" must be a symptom, but not the root cause, because the database is in multi-user mode with 0 connections (except an aiw, biw, and wdog). And everything worked when the connection was local.

I was using a single proserve command with these options:
-c 200 -L 20000 -B 75000 -n 7 -bibufs 25 -aibufs 50 -spin 72000
-bistall -bithold 8000 -tablerangesize 200 -indexrangesize 400
-H -S jrsutps1 -minport 7121 -maxport 7129

but I tried splitting into 2 different ServerTypes:

$DLCBIN/proserve $DB $* \
    -c 200 -L 20000 -B 75000 -n 10 -bibufs 25 -aibufs 50 -spin 72000 \
    -bistall -bithold 8000 -tablerangesize 200 -indexrangesize 400  \
    -Mpb 2 -Mn 6 -ServerType 4GL -Ma 10 -Mi 10
$DLCBIN/proserve $DB    \
    -m3                 \
    -H -S jrsutps1 -minport 7121 -maxport 7129 \
    -Mpb 2 -Mn 6 -ServerType SQL -Ma 5 -Mi 5

but that had no effect.

Advice and help requested ! TIA - Jim

All Replies

Posted by gus bjorklund on 11-Apr-2017 21:29

first thing you should try is to raise -n to a much larger value (say 20 or 50). you currently have a value much less than the default.

Posted by bronco on 12-Apr-2017 01:22
Posted by bronco on 12-Apr-2017 01:23

Oops, I read poorly. You already splitted the servers.

This thread is closed