progress developer studio error

Posted by jose baca on 11-May-2016 18:24

Hello guys, I´m getting this error: only PARAMETERS defines allowed inside a procedure prototype (6540), and the editors marks is in the read-only code part. I got this error after creating or importing .w file with ABL UI design without doing nothing. I just create the .w file and the error appears without doing nothing. I hope you can help me out, I realy appreciated. Thanks!

All Replies

Posted by Anil Kumar on 11-May-2016 19:07

Hi Jose baca,

Can you please provide more details on the problem:

1) Which version of PDS OE and

2) Type of Appbuilder file (say SmartWindow, SmartDataObject, etc) you are creating in OpenEdge project via ‘New ABL UI Design’ dialog.

Also, can you please attach the Appbuilder auto-generated file which possess compilation errors in it.

Thanks and Regards,

Anil Kumar.

Posted by Håvard Danielsen on 11-May-2016 19:37

One possible explanation is that  the .w was created from a template that has a bad procedure prototype directly in the source or in an include file defined in the source.

Your propath definition decides which templates and include files that are being used.

If the error is fromthe include file you should probably start by looking at this.  

To see which template is being used look at the Template field below the Object type selection list before you press Finish or Next in the  New ABL UI Design wizard when creating the .w file.  


The templates are defined  in various .cst files available in the project.  There is a set of default .cst files, but the list of .cst files can also be customized, in which case they will be stored in the .ini file or registry in a "CustomObjectFiles" section.  You can also see and edit this list by right clicking on the palette and select "Use Custom ..". (Note that the palette will only show up if you have an .w in the design editor though). Note that propath also decides which .cst files are being used.  

Posted by jose baca on 12-May-2016 11:04

I´m using progress 11.6, yes I´m creating SmartWindow also try with SmartFrame and SmartDialog via new ABLUI design wizard, and I have same error, but when I try a Window object it works fine.

Also when I drag an drop SmartWindow file I got same error.

this the code with the error

Posted by jose baca on 12-May-2016 11:22

Hi Havard, I tried replacing the files: the template (src\adm2\template\cntnrwin.w), and these three include files that are in the auto generated code ( adecomm/appserv.i, src/adm2/widgetprto.i, src/adm2/windowmn.i). I replaced these files with the same files from a working progress installation files form my partner´s computer. but I have same error.

This thread is closed