WebControl and Windows 10 - Edge

Posted by goo on 18-Apr-2016 10:12

OE11.6

I am using the webcontrol for a webapplication that is using ActiveX and after going for windows 10, the webcontrol seems to use the Edge instead of InternetExplorer. The Edge is not supporting the ActiveX components that is used in the application, so I need to start it with an older version. Before going for Win10 I had to set it like this:

 

        ProgressKey = Microsoft.Win32.RegistryKey:OpenBaseKey(Microsoft.Win32.RegistryHive:CurrentUser, Microsoft.Win32.RegistryView:Registry64).

        ProgressKey = ProgressKey:CreateSubKey("Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION").

        ProgressKey:SetValue("prowc.exe", 0).               

 

I have tried to set it to both 10 and 11 without any luck.

 

Anyone have a clue how I can get it to work? I can get around the problem by forcing internet explorer using process().... start()..... but then it is staring an external window. I would prefer to start it in a container.

 

//Geir Otto 

All Replies

Posted by Garry Hall on 18-Apr-2016 11:21

If I understand you correctly, you are embedding a web browser ActiveX control in an OE window. This used to load IE as the browser control, but now it loads Edge. Is this correct? If so, how are you loading the web browser control?

Posted by goo on 18-Apr-2016 16:24

That is correct. I am not sure what you mean with 'how are you....'. I uses a class that implements something like this:

Is this what you wanted to know?

:

:

METHOD PUBLIC OVERRIDE VOID InitializeComponent(  ):

THIS-OBJECT:webBrowser1 = NEW System.Windows.Forms.WebBrowser().

   THIS-OBJECT:SuspendLayout().

   ProgressKey = Microsoft.Win32.RegistryKey:OpenBaseKey(Microsoft.Win32.RegistryHive:CurrentUser, Microsoft.Win32.RegistryView:Registry64).

   ProgressKey = ProgressKey:CreateSubKey("Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION").

   ProgressKey:SetValue("prowc.exe", 0).                

   /*  */

   /* webBrowser1 */

   /*  */

   THIS-OBJECT:webBrowser1:Dock = System.Windows.Forms.DockStyle:Fill.

   THIS-OBJECT:webBrowser1:Location = NEW System.Drawing.Point(0, 0).

   THIS-OBJECT:webBrowser1:MinimumSize = NEW System.Drawing.Size(20, 20).

   THIS-OBJECT:webBrowser1:Name = "webBrowser1".

   THIS-OBJECT:webBrowser1:Size = NEW System.Drawing.Size(667, 329).

   THIS-OBJECT:webBrowser1:TabIndex = 0.

/*        THIS-OBJECT:webBrowser1:Url = NEW System.Uri("http:\\www.vg.no", System.UriKind:Absolute).*/

   /*

   THIS-OBJECT:webBrowser1:Url = NEW System.Uri("file:\\C:\tmp\test.swf", System.UriKind:Absolute).

   */

   THIS-OBJECT:webBrowser1:ScriptErrorsSuppressed     = TRUE.

   THIS-OBJECT:webBrowser1:WebBrowserShortcutsEnabled = FALSE.

   THIS-OBJECT:webBrowser1:DocumentCompleted:Subscribe(THIS-OBJECT:webBrowser1_DocumentCompleted).

   /*  */

   /* WebBrowser */

   /*  */

   THIS-OBJECT:ClientSize = NEW System.Drawing.Size(667, 329).

   THIS-OBJECT:Controls:Add(THIS-OBJECT:webBrowser1).

   THIS-OBJECT:Name = "WebBrowser".

   THIS-OBJECT:Text = "WebBrowser".

   THIS-OBJECT:ResumeLayout(FALSE).

   CATCH e AS Progress.Lang.Error:

     UNDO, THROW e.

   END CATCH.

 END METHOD.

Posted by goo on 18-Apr-2016 17:26

I have now tried to set the Feature_browser_emulation = 10001 and other values like 10000, but now it seems like it stop loging in.. .just hangs like it has freezed... strange

Posted by Garry Hall on 18-Apr-2016 20:46

Thanks for the clarification. You are using the .NET API, System.Windows.Forms.WebBrowser. Older applications use the IE COM object through OpenEdge's COM interface, so I wanted to understand which approach was being used.

The doc I read is vague. I found nothing authoritative say that WebBrowser uses Edge at all. I came across social.msdn.microsoft.com/.../project-spartan-and-the-webbrowser-control, which I am guessing you have already seen. I have nothing further to offer that you can't find on Google.

Posted by goo on 20-Apr-2016 03:42

Do anyone know about another browser control that can be used, that uses i.e. Opera or Firefox or somethiing else that can use NPAPI ? Staring to get really enoyd by the WebControl and IE.... I am able to use IE by changing FEATURE_BROWSER_EMULATION to 10001, but when running control.easyinspect.no:6103 it hangs/freeze when in WebControl, not when running without WebControl... and I am not sure how to debug this... Willing to pay for a fix :-)

Posted by goo on 20-Apr-2016 03:50

Forgot to add, that this is only a pain when using windows 10 ....

Posted by Matt Baker on 20-Apr-2016 08:30
NPAPI was removed from chrome a while ago
 
 
and it is being removed from firefox by end of this year
 
 
 
This thread is closed