OE 11.6 AppBuilder 'Editing Options'

Posted by Grant Holman on 09-Nov-2015 07:48

Hi

I've just installed OE  11.6 Classroom edition.  As I come from a 9.1 environment I started by looking at the Appbuilder and noticed that I'm not getting any 4GL syntax formatting (e.g. auto capitalizing of keywords, colour coding etc).  This is controlled under Options -> Editing Options... in 9.1 Appbuilder, but this menu item is missing in 11.6.  Can anyone point me to where this is now?

Thanks

Grant

All Replies

Posted by Mike Fechner on 09-Nov-2015 07:51

Assumingly the classroom Edition does only contain a Progress Developer Studio license.

In that case, there is no color-coding in the classic AppBuilder/Procedure Editor. You should have a look at Progress Developer Studio (Eclipse based) instead.

Posted by James Palmer on 09-Nov-2015 07:56

There are a number of presentations from previous PUG conferences around how to get the most out of Developer Studio that are probably worth looking at. In fact Mike is one of the authors of a good one I remember.

His colleague Marko did a good introduction last year in Dusseldorf: emeapug.myweb2go.co.uk/.../marko_ruterbories_IntrotoPDSOE.pdf

Posted by Bill Wood on 09-Nov-2015 08:22

WRT

>>> Assumingly the classroom Edition does only contain a Progress Developer Studio license.

Yes.  "Classroom Edition" is basically the full installation of a Progress Developer Studio (64-bit Windows), from the perspective of what is installed, and what you have access to.

Posted by Grant Holman on 09-Nov-2015 08:24

Thanks for your replies.  I'll start looking at Studio shortly - does it effectively make Appbuilder redundant?

Posted by Mike Fechner on 09-Nov-2015 08:27

AppBuilder is an integrated Feature.

It makes "OpenEdge Studio" (the classic AppBuilder license) redundant.

Posted by keithg on 10-Nov-2015 09:01

From what I understand, the colorized syntax in the old, stand-alone AppBuilder is gone for good, much to the chagrin of those of us that still use it.  (It was still there in 11.2, but disappeared in a later version.)  I'm guessing it happened because either (1) Progress would/could no longer pay to license the underlying SlickEdit editor technology used to implement the colorized syntax, or (2) removed it in an effort to push developers toward the Eclipse-based environment.

Posted by Lieven De Foor on 10-Nov-2015 09:37

Why would you still need the stand-alone AppBuilder when all functionality is available in the Eclipse plugin version?

I completely understand why Progress doesn't invest in the classic AppBuilder anymore.

That would seem like a waste of resources to me, when you've got something newer and better...

Posted by Mike Fechner on 10-Nov-2015 10:02

You can still get the colored old style Editor when installing 32 bit OpenEdge Studio.

But I am with Lieven. Give Progress Developer Studio a Chance and increase your productivity!!!

Posted by Matt Gilarde on 10-Nov-2015 10:05

There are a couple of factors involved. SlickEdit is expensive. We have limited the products we ship it with to keep the ever-rising licensing costs in check. Due to technical issues we couldn't integrate SlickEdit with the 64-bit products. We're looking into a replacement for SlickEdit. I'm not promising anything, but If we go with a free replacement we may restore color coding to the products which have lost it, including the 64-bit products.

Posted by rayherring on 10-Nov-2015 18:40

Except that not all AppBuilder functionality is available in the Eclipse plugin version or Progress Developer studio.

We use ps:escript for our web development work (really too late to change now as we are heavily invested in ps:escript), and for that, I need the AppBuilder as it gives me access to the ps:escript Explorer, ps:escript Editor, and, the AppBuilder also has a 'remote development' mode that we use at work, with that button clicked, all I have to do is click on 'open' and it gives me a server directory browser instead of a local filesystem browser.

If all those options were available to me in the Eclipse version or Progress Developer Studio then I would use it, I have tried using PDS and connecting it to the remote database server, however with my crappy ADSL2+ connection and the size of the DB, when I open the database browser in PDS it generally takes several minutes to browse the DB.

Posted by Grant Holman on 11-Nov-2015 02:38

So Appbuilder is now crippled - losing syntax formatting is a huge loss.  Looks like OE Studio is the way to go then.

I've just opened up a .w in Studio and set the Perspective to 'OpenEdge AppBuilder'.  I can see a Procedure Editor like pane with the source nicely coloured but where is the actual gui screen so I can directly edit it (a la AppBuilder)??

Posted by Mike Fechner on 11-Nov-2015 02:41

right-click on the source and choose "View Design" from the context menu.

Posted by Grant Holman on 11-Nov-2015 03:11

Thanks, I did that but don't appear to have a 'View Design' option:

Posted by Grant Holman on 11-Nov-2015 05:03

I created a new .w and now I can see the window design correctly for this but still can't see the window for the existing .w.

Posted by Håvard Danielsen on 11-Nov-2015 06:59

It seems as you're .w is not in a Developer Studio project. This assumption is based on the fact that the Check syntax and Compile menus are disabled. This can also happen when the Progress executable has stopped/crashed, in which case you may be able to restart it from the Project > Restart OpenEdge AVM  menu.

Posted by Håvard Danielsen on 11-Nov-2015 07:18

When you open a file that is a supported ABL file from the file system and the file is not in a project, you can also see that the file icon with the extension character (.w, .p, .i, .cls)  inside of it is different from the icon shown for a file in a project. The character inside the icon is white (or something). Files in the project are typically opened from the Project Explorer.

Posted by Grant Holman on 11-Nov-2015 07:39

Hello Håvard, thanks for your replies.  You are correct - the .w has opened with a '.w' icon on its tab.  How do you add existing files to a project then?

Posted by Håvard Danielsen on 11-Nov-2015 08:04

Note that It will have a .w icon also when opened from the project, but the letter/character is dark.  

I believe you can select menu File -> Import and select File System do import existing files to a project. I believe you also can drag and drop from Windows Explorer to the Project Explorer. Note that if you drag and drop to the Editor it will just open the file. (I'm a bit hazy on this as I've almost never done this, I usually do this the other way around as described below)  

If you have a folder with many .w you can alternatively make the existing folder to a project folder. You do this by selecting menu File -> New -> OpenEdge Project and uncheck the Use default location and use the Browse button to find the folder.

In both cases you will  need to add propath definitions and database connections to the project. You can do this when walking through the Project wizard with the Next button or you can add them later from the Project -> Properties menu.

Posted by Matt Baker on 11-Nov-2015 08:35
 
AppBuilder ships with PDSOE. 
 
You can use it standalone, but you lose the color coding and some formatting; or you can use it embedded and gain access to all the IDE features provided by PDSOE. 
 
In more recent versions (11.5+) the embedded functionality was redone and is now fairly nice.
 
mattB
 
 
 
Posted by Peter Judge on 11-Nov-2015 08:38
Also, if you have opened a file and have the wrong editor (ie text) you can right-click and select Open With ... . Whatever you choose there will then be used.
 
Posted by Grant Holman on 11-Nov-2015 09:27

Håvard - Thanks, both the drag'n'drop and Import methods worked.  The file icons in the Project Explorer View have little red boxes with a white 'x' in them - do you know what this signifies?

Matt - funnily enough the missing colour coding in AppBuilder was what sparked this thread.

Posted by Håvard Danielsen on 11-Nov-2015 09:44

The files get red markers when they don't compile. Make sure you define the required database connections and propath for the project.  You can open the file and check syntax to see what is wrong.

Posted by Grant Holman on 11-Nov-2015 10:01

Great, my PROPATH was missing a folder.  I like the way the files were rechecked automatically after I amended the propath.

This thread is closed