Convert target "UTF-8" Fails

Posted by hauahei on 06-May-2015 03:11

Hi. I have a program where I generate serveral files to disk in different procedures.

All output files (text files) are converted to UTF-8 (cpinternal and cpstream is ISO8859-1) using CONVERT TARGET "UTF-8" in the "output stream to  <filnavn>" statement.

This works fine on most files but not on one file. this is straigth forward PUT statements inside a For EACH.

This has always worked for my before and I can't find out why this partically output dosen't convert.

If someone have had a simular problem and solved it, I would appriciate any input. 

I am blind here.

progress version 11.3.2 on unix (aix).


All Replies

Posted by Garry Hall on 06-May-2015 07:18

Please provide more information on what "fail" means. When it doesn't work, what happens? Is there an error message? Or is the text malformed? Or is data missing?

Without knowing more about what you are doing, and how it is failing, it is hard to provide a useful answer. I would also suggest contacting Technical Support for assistance.

Posted by mihai.pintea on 09-May-2015 06:42

From the experience I had with these kind of errors, my only guess would be that there is one or more non-convertible characters in the file. (might be a strange name, some weird description ...)

But as Garry said, it would be great to detail what means "output doesn't convert". Error message, file doesn't look OK, or what?

This thread is closed