Issue attempting to run PDSOE 11.4

Posted by Mark Davies on 21-Jan-2015 23:38


I've been struggling to run my PDSOE 11.4 (32bit on Windows 8.1) successfully - the same is happening with 11.3 but not with 11.2, making me think that something has changed between 11.2 and 11.3 and up.

I get two errors - the first being (com.progress.ipccom.IPCException: Permission denied: listen):

It then continues to open Eclipse and as long as I do not attempt to create a new ABL Form (or any other visual object) I can work in Eclipse and the ABL compiles my object.

However, as soon as I open a visual object that needs to launch the Visual Designer I get the following message (almost immediately):

com.progress.ipccom.IPCException: No connection could be made because the target machine actively refused it

It all looks like it could be firewall related, but I have disabled my AVG, I then also tried to Allow All on the firewall settings on AVG and even allowed all connections for Domain, Private and Public on the Windows Firewall setting but no luck.

I also tried changing the port ranges in the Startup settings on PDSOE from 3333 - 3343 to a higher and lower port range - same message every time.

Anyone else had this issue, found any solution?

Thanks in advance,


All Replies

Posted by Srinivas Kantipudi on 18-Feb-2015 02:46

Mark, would it be possible to share your project? We have seen this error before in a very specific case, like when IP addresses changes frequently and when trying to connect to remote machine via VPN etc. Can you think of anything specific in your environment that might be causing this issue?



Posted by Mark Davies on 18-Feb-2015 03:00

Uninstalling my AVG antivirus program resolved my issue. Not being ideal and with no feedback from AVG on a possible way to fix it, it was my only solution.

Posted by Mark Davies on 18-Feb-2015 03:03

Hi Srini,

I had to completely uninstall my AVG to get this to work. I still have a 1 year left on my license - so, that is a bummer, but with no feedback from AVG on how to overcome this issue I had to give up and do what I needed to be able to continue with my work.

If you know of any proven way to get  this running with AVG, then I would most definitely be very grateful.

Posted by Mike Fechner on 28-May-2015 04:05

Hi Mark, did you ever get further on this without uninstalling your Anti-Virus/Firewall solution?

Posted by Mark Davies on 28-May-2015 04:36

Hi Mike,

No, I tried to contact AVG about this but had no response - which was a pain, cause I still had 8months left on my license. I had to uninstall it and get a different antivirus - purchased Bitdefender now and this doesn't have the same problem.

This thread is closed