Debugging AblUnit

Posted by Mike Fechner on 03-Dec-2014 05:01

AblUnit Tests launch configurations do only appear in the Run menu - not in the Debug menu.

Is that a bug or a feature?

How can we debug our unit tests or the actual code which is being tested without having to create a .p file that instantiates the test class and executes the test method?

All Replies

Posted by Swathi Yellavaram on 26-Feb-2015 06:41

Hi Mike,

Debugging ABLUnit tests is not implemented. As you mentioned, currently the only way is to write a procedure/class that executes the test.

Thanks,

Swathi.

Posted by Mike Fechner on 26-Feb-2015 06:45
Hi Swathi,
 
any plans to fix that in 11.6?
 
It just makes soooo much sense to be able to debug unit tests when they fail.
 
Regards,
Mike

Posted by Srinivas Kantipudi on 26-Feb-2015 07:28

Mike, can you please post this in Ideas section? We will also send this to Product Management for consideration.

community.progress.com/.../default.aspx

Thanks,

Srini

Posted by srireddy on 20-Feb-2017 07:25

Hi Mike,

This has been implemented in 11.7 and you can give it a try in the latest OpenEdge 11.7 ESAP 6  release which was released on 18th February.

Please give it a try and let us know your comments.

Thanks,

Nischal Y

Posted by Mike Fechner on 20-Feb-2017 15:58
Hello!
 
I’ll be testing this this week and will report back.
 
Thanks,
 
Mike
Von: srireddy [mailto:bounce-srireddy@community.progress.com]
Gesendet: Montag, 20. Februar 2017 14:26
An: TU.OE.Development@community.progress.com
Betreff: RE: [Technical Users - OE Development] Debugging AblUnit
 
Update from Progress Community
 

Hi Mike,

This has been implemented in 11.7 and you can give it a try in the latest OpenEdge 11.7 ESAP 6  release which was released on 18th February.

Please give it a try and let us know your comments.

Thanks,

Nischal Y

View online

 

You received this notification because you subscribed to the forum.  To unsubscribe from only this thread, go here.

Flag this post as spam/abuse.

 
This thread is closed