Installing 32 bit OE10.2A on 64 bit windows 7

Posted by MBeynon on 04-Nov-2014 02:22


According to the knowlegde base this should be possible but I have run into difficulties. After downloading and installing 10.2A from the Progress download center (alog with the licenses) I don't seem to be able to create a new project in Eclipse. I get the following error:

"The selected wizard could not be started.
  Plug-in com.openedge.pdt.text was unable to load class com.openedge.pdt.text.wizards.OENewProjectWizard.
  An error occurred while automatically activating bundle com.openedge.pdt.text (25)."

I installed OpenEdge into a folder on my C drive called dlc10 and have set the environment variable DLC to C:\dlc10. Other apsects of the installation such as the appbuilder work OK, it's just Eclipse.

Has anyone else experienced this?



P.S. When trying to patch my install up to 02 I get the following error:

Exiting Install
OpenEdge r10.2A installation corrupted:

   "DLC" registry key not found.

Click OK to exit.

So, it looks like something has not installed correctly.

All Replies

Posted by Nicolas on 04-Nov-2014 02:26


Do you have launch your install with Administrator profil (right clic > Execute as Administrator) ?


Posted by MBeynon on 04-Nov-2014 02:29


I tried this but it made no difference.



Posted by Frank Meulblok on 04-Nov-2014 03:02

Chances are you're one of the many unfortunate victims of a nasty installer bug that leaves bad registry keys.

See for more details, and

Posted by MBeynon on 04-Nov-2014 07:51

Thanks, I ran the registry fix on the KB and it allowed me to patch the install to 02 but now I get this error when trying to run Eclipse:

java.lang.RuntimeException: No application id has been found.



at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(

at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(



at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(

at sun.reflect.DelegatingMethodAccessorImpl.invoke(

at java.lang.reflect.Method.invoke(

at org.eclipse.equinox.launcher.Main.invokeFramework(

at org.eclipse.equinox.launcher.Main.basicRun(


at org.eclipse.equinox.launcher.Main.main(

This is my start up command:

C:\dlc10\oeide\eclipse\eclipse.exe -showlocation -vm "C:\dlc10\jre\bin\javaw.exe"

Posted by DivyaTheja on 04-Nov-2014 20:48

Hi Beynon,

Please try re-installing architect's plugins with following steps.

1. Open Proenv.

2. Run following commands.

<DLC>\oeide\integrateArchitect -uninstall <<DLC>\oeide\eclipse

<DLC>\oeide\integrateArchitect -install <<DLC>\oeide\eclipse

Also, KB article might help.

Hope this helps,


Posted by MBeynon on 05-Nov-2014 03:07


Unfortunately, I don't have "integrateArchitect" in my oeide folder, perhaps because I'm installing version 10.2A?


This thread is closed