Locked in AppBuilder's Debug H*LL...

Posted by tbaxter9999 on 15-Oct-2014 11:34

We're running Progress V10.2B, and when I opened a structured procedure, and selected: Compile > Debug, it opens up a  blue Progress character window with a title of “Status” and the message:

  “Initializing Character Run Window…”

  Which does nothing… pressing any key hides this window, but subsequent selections of

         Compile > Run

  From the AppBuilder’s menu bring up this same blue window, with no obvious way to turn off this debug window

  It appears that we might be locked in “Debug mode” with no way to exit, and it’s possible that we don’t have the Debugger installed on our system… I’ve tried the

           proDebugEnable -disable-all  

   from a DOS prompt, and it doesn’t seem to do anything to change the situation...

Can anyone explain what is going on, and how I can get back to a normal program RUN when I select Compile > Run from the AppBuilder menu?

thanks, all



All Replies

Posted by Dileep Dasa on 16-Oct-2014 02:36

I tried to debug a structured procedure. I didn't have debugger enabled and got a message asking to enable debugger. Then, I enabled debugger, closed and opened AppBuilder and then did Compile -> Debug once again. As expected, Debugger appeared with code of the structured procedure.

>>  it’s possible that we don’t have the Debugger installed on our system

Can you please let us know the components you have installed?

To check if enable/disable of the debugger occurred correctly, see following registry key:


Also when you see blue Progress character window, before pressing any key on it, just scroll down to end of the window to see if there are any messages.

This thread is closed