MIndFusion - Exception has been thrown by the target of an i

Posted by tbergman on 28-Mar-2014 05:46

I want to add a flow chart type of view to our application. I downloaded a set of controls from MindFusion and installed them. It appears their installation does not add the controls to the GAC so I copied the DLLs to my project, added assembly references and successfully added the controls to the toolbox in visual designer.

The error above occurs when I try to drag a DiagramView control to my form. A Kbase search reports that the same error can occur with the Infragistics controls if they are not properly licensed. I suspect this may be the problem as I downloaded a trial version.

The controls work fine in Visual Studio.

Is there a way to get these working in Progress? Are there similar controls others have used in Progress that you can recommend?



All Replies

Posted by tbergman on 28-Mar-2014 13:41

Well, I solved (sort of) this issue. It turns out that the project I tested with in Visual Studio had a licences.licx file. Copying this to the assembles (and all the dlls) location allowed it to work.

I still don't know why some vendors refuse to register their DLL's in the GAC. I hate the idea of deploying 20 or so DLLs in the assembles file location. What are others doing? Writing your own installation and adding to the GAC? Deploying in the assembly file location? Something else?


This thread is closed