OpenEdge Debugger incorrectly displays the characters in 125

Posted by Valeriy Bashkatov on 09-Dec-2013 05:40


I have the following problem with the OpenEdge Debugger, see picture:

In we have defined 1251 character set:

-cpinternal 1251
-cpstream 1251
-cpcoll Russian
-cpcase Basic

How to set the correct character set for the correct display russian characters in the OpenEdge Debugger?

I will be grateful for any help.



All Replies

Posted by Paul Clare on 09-Dec-2013 06:56

Hi Valery, I believe the debugger expects the compile listing in UTF-8, and unfortunately this can't be changed.  I could get this to work by using

-cpinternal 1251 -cpstream UTF-8

to create the UTF-8 source file, and then debugging it with:

-cpinternal UTF-8 -cpstream UTF-8

But I wouldn't suggest this is a solution.  I haven't tested it, but I believe the Developer Studio debugger does this correctly if started with the correct code page settings.



Posted by Jean Richert on 09-Dec-2013 14:11

[mention:e212de63058742feaea9dcd68d904754:e9ed411860ed4f2ba0265705b8793d05], I think a question related to the OE Debugger is more relevant in the OE Development forum than OE RDBMS.. Do you agree? if so then I'll move it.  

Posted by Valeriy Bashkatov on 10-Dec-2013 00:52

Thank you, Paul!

I will check this solution.

Posted by Valeriy Bashkatov on 10-Dec-2013 00:52

Hi Jean!

Of course I agree.

This thread is closed