OE11.3.1 Progress Developer Studio - 11724 debugger error

Posted by Admin on 03-Oct-2013 14:02


I am getting a 11724 error "process not debug enabled. run prodebugenable via proenv" when trying to run the debugger in progress developer studio. I have ran the prodebugenable command via the proenv but the error is still occurring. I don't remember having to enable debugging in any previous installs when running the debugger via studio.

Has anybody had this problem?

This is a new OE11.3.1 install and the debugger did work in 11.2.



All Replies

Posted by DivyaTheja on 03-Oct-2013 16:03

Hi Craig,

The problem here is that for enabling the debugging, user must have logged in as root/administrator.
As an alternative, for enabling the debugging, the value of C:\Progress\OpenEdge.state in registry key HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS\ProDbgCK has to be changed from Debugging disabled to Debugging enabled.

Hope this helps,

Posted by Admin on 03-Oct-2013 17:06

Hi Divyatheja,

Thanks for the reply.

I have openedge 10.2B07 and 11.3.1 installed on the same machine. Would this be causing the problem?

I went into the registry and the ProDbgCK registry key has two entries.

one referencing my Openedge 10.2B install


and the other the 11.3.1 install


I change the both reg value to what you said but still getting the same error and with a follow up error saying the debugger can not connect to the AVM.



Posted by Dileep Dasa on 04-Oct-2013 00:11

Hi Craig,

Having 10.2B07 and 11.3.1 installed on the same machine should not be a problem.

For resolving "cannot connect to AVM problem", please try increasing the connection time out which is used by the Debugger to connect to the OpenEdge Client:

Window --> Preferences --> Progress OpenEdge --> Debug --> Connection time-out (ms)

Thank you,


Posted by riche on 16-Jan-2015 13:15

I had this issue and was able to resolve it by closing PDSOE, running the "prodegubenable -enable-all" in proenv, then opening PDSOE by right-clicking and using the the Run as administrator option. I clicked the debug button in the toolbar and got the prompt to turn it on, which I clicked on the yes button and it worked as it should. I then exited PDSOE and re-opened it normally and was able to debug.

This thread is closed