OEA Crashing & burning on startup...

Posted by ChUIMonster on 02-Mar-2009 13:46

I had a poorly planned shutdown of my desktop a little while ago and now when I try to restart OEA it comes up, teases me for a moment (just long enough to move my mouse and, maybe, click on something) and then it vanishes...

I'm hoping that some trick short of re-installing OEA might fix the problem...

Poking around some I found a file called .log which contains entries like this:

I don't think the "refreshing workspace" step is actually working though because there are a great many sections like this (all from this afternoon).

I have rebooted several times. It doesn't help.

All other Progress related functions of this machine work fine. Actually everything except for OEA is apparently working fine. But OEA seems quite offended by my failure to exit it cleanly prior to the reboot.

(In the interest of gruesomely full disclosure... OEA was running on the secondary screen of a 2 screen desktop. Both screens are portrait mode 1200x1920 monitors. At the time that I so carelessly failed to shutdown a project was open and I was fiddling with physically moving the monitors for improved comfort. This resulted in a power loss and eventually a reboot.)

All Replies

Posted by Thomas Mercer-Hursh on 02-Mar-2009 13:57

Have you tried staring with -clean?

Posted by ChUIMonster on 02-Mar-2009 14:04

I always use -clean. Mike told me to

Posted by ChUIMonster on 02-Mar-2009 14:06

I think I fixed it. I removed the version file in .metadata and it magically reappeared and OEA started up properly.

Just to make sure i went through a nice orderly refresh, "clean" and closing of the project. Then I shut down, restarted and re-compiled. Everything seems to be ok now.

Posted by Thomas Mercer-Hursh on 02-Mar-2009 14:17

Well, I do too, but it isn't the default.

Posted by ChUIMonster on 02-Mar-2009 14:50

Line 6 of the .log output...

Posted by Thomas Mercer-Hursh on 02-Mar-2009 15:02

Details ... you don't expect anyone to actually read all that cr*p, do you?

Posted by egarcia on 03-Mar-2009 08:16

Hello Tom,

I am glad that OpenEdge Architect is starting up again for you.

My suggestion would have been to try with a new workspace to trouble shoot the issue or use it as a workaround (import the projects into the new workspace).

Regarding the -clean option. The -clean option is generally used to tell Eclipse to detect new plugins and it does not need to be used in a regular basis.

If you have a large number of plugins available to the environment, then the clean operation would take some time.

Hope this helps.


Posted by Admin on 03-Mar-2009 14:21

Hi Tom, Hi Edsel,

I usually run with the -clean option. It's a old habit of mine. The time it takes is acceptable on todays machines.

The reason for this habit is the fact that I usually have a number of different workspaces (one per customer with a number of different projects) and I create a folder with various shortcuts for each customer. This also includes a shortcut for launching OEA with specialized parameters (vmargs, -data, etc.). -clean is usally on the list as well, because sometimes I play around with some plugins that are not installed using Eclipses update manager (jar just copied to the plugin directory).

I'd need to have a separate -clean shortcut for all of my projects. So it's just a lazy man decision to always go with -clean. Other than time for a sip of extra coffee in the morning, is there anything wrong with -clean by default?


Posted by egarcia on 03-Mar-2009 16:43

Hello Mike,

I understand why you are using the -clean option.

In previous versions of Eclipse, I think using -clean by default was ok.

I have only seen issues with Eclipse 3.4.

While testing configurations with OpenEdge Architect 10.2A (Eclipse 3.4),

I noticed that there may be configuration issues if the plugins available to the environment have conflicts.

A potential issue then is that if there are conflicting plugins, the -clean would create a new configuration where plugins available in the prior configuration would be missing.

Also, a side effect of using -clean with Eclipse 3.4 is that a new configuration would be created and added to the list of previous configurations (some few Mb). (The Revert Configuration option in the Software Updates dialog uses this list.)

For Eclipse 3.4, I prefer to use the dropins folder, instead of copying plugins to the plugins directory. Eclipse monitors the dropins folder and then configures the plugins. The -clean option is not needed when using the dropins folder.

For cases when I need to copy plugins to the plugins directory (and features), I have a batch file that performs a clean using the p2 director application.

There is an OpenEdge Developers Corner session about using 3rd party plugins and OpenEdge Architect that may be useful:

Title: Leveraging 3rd party Plug-ins

Link: http://www.psdn.com/library/entry!default.jspa?categoryID=2130&externalID=6100&fromSearchPage=true



This thread is closed