Visual designer ports

Posted by jmls on 22-Mar-2011 07:24

10.2B 03

Still having this problem with my laptop

Whenever I restart Architect, I get the message

"Cannot find available port within the required range 3333 <-> 3343"

I've tried resetting the ports in config (get the same message, different port numbers)

I've even now tried uninstalling openedge, installing and then installing service packs

still no go.


All Replies

Posted by egarcia on 22-Mar-2011 09:21


Are you using Windows 7 64-bit or Windows 2008 64-bit?

If so you might running into an issue with Java 1.5 where the  TCPV6 listening socket is left open.

If this is the issue you could try adding the following option to the eclipse.ini file (DLC/oeide/eclipse) as a -vmargs:

you could also add -vmargs to the shortcut for Architect, however, this would override the parameters specified in the eclipse.ini file.

You could use netstat -a or the TCPView utility from Windows Sysinternals to see the activity on TCP ports.

I hope this helps.

Posted by jmls on 22-Mar-2011 11:41

hope for a little while, cruelly dashed. Running 32 bit windows 7

Posted by egarcia on 22-Mar-2011 12:47

Sorry that I did not explain the the scenario with Java 1.5 and IPV6 correctly.

The issue is not specific to the system being 64-bitbut it was seen in those environments.

This might still be the issue if you are using IPV6.

Are you using IPV6?

Do you see a difference in behavior after using the parameter for the JVM?

Do you see this behavior the very first time that you restart Architect, or after restarting it several times?

I hope this helps.

This thread is closed